-   Linux - Hardware (
-   -   [Fedora 16] Asus N55SF Graphics (

rpcaldeira 12-04-2011 03:39 PM

[Fedora 16] Asus N55SF Graphics
1 Attachment(s)
Good Afternoon guys, i have a Asus N55SF-S1084V and I'm running Fedora 16. I'm having a problem because my monitor supports resolutions up to 1920x1080. But since Fedora shows my monitor as "Unknown", it only shows three "crappy" resolutions (800x600, 1024x768, 1280x1024). I've heard about using xrandr but i'm not too familiar with it. Can anyone help me?

If additional information is required, i'll be glad to provide it.

And BTW, GNOME Shell does not work, it always start in fallback mode. Does anyone know how to fix this?

Thanks in advance.

adamk75 12-05-2011 11:11 AM

Please show us your /var/log/Xorg.0.log file.


rpcaldeira 12-05-2011 03:13 PM

[Fedora 16] Asus N55SF Graphics
1 Attachment(s)
Hello Adam, Thank You for taking the time to help me.

The file is attached to this post (It it too big to put in text).

Thanks Again for your help :)

adamk75 12-05-2011 05:37 PM

You have installed the nvidia proprietary drivers, but have not configured Xorg to use those drivers.

However, I am doubtful you can even use the nvidia GPU on that laptop at the present moment. Laptops with nvidia GPUs provided via Optimus are unsupported by both nouveau and the nvidia driver, though some folks have reported success with projects known as Ironhide and Bumblebee.

First, remove the nvidia drivers. Do you have an /etc/X11/xorg.conf file or anything under /etc/X11/xorg.conf.d/ ?


rpcaldeira 12-06-2011 02:26 PM

[Fedora 16] Asus N55SF Graphics
1 Attachment(s)
Ok, here is the deal, when I removed the nVidia drivers, the system went "KABOOM", it wouldn't boot, so I've formatted it. But as expected the problem continues.

Since it is all new, I've uploaded a new version of the Xorg log file, and my xorg.conf it's described below


[rpcaldeira@N55SF X11]$ cat xorg.conf
Section "Device"
Identifier "Videocard0"
Driver "vesa"
As for the /etc/X11/xorg.conf.d/ folder, i have only one file.
This file is described below


[rpcaldeira@N55SF xorg.conf.d]$ cat 00-system-setup-keyboard.conf
# This file is autogenerated by system-setup-keyboard. Any
# modifications will be lost.

Section "InputClass"
Identifier "system-setup-keyboard"
MatchIsKeyboard "on"
Option "XkbModel" "pc105"
Option "XkbLayout" "pt"
# Option "XkbVariant" "(null)"
Option "XkbOptions" "terminate:ctrl_alt_bksp,"
Thanks man, again ;)

adamk75 12-06-2011 02:51 PM

Did you do anything to generate that xorg.conf file. Fedora 15, at least, didn't have an xorg.conf file by default, and I'd be surprised if F16 does. That's forcing you to use the vesa driver. In addition, you are passing the "nomodeset" option to the kernel, which is going to disable kernel modesetting. That will also force you into using the vesa driver on your Intel GPU.

Remove the xorg.conf file, remove the "nomodeset" option, reboot, and try again.


rpcaldeira 12-06-2011 03:18 PM

It's working!!!!!!!!!!!!!!!!!!!!! Thanks. Look if it's not too bother, how do I remove the nomodeset option permanently from the kernel. I only know you to remove it at boot time in the grub configuration screen...

if you could help me with this one last step...

Thanks ;)

adamk75 12-06-2011 03:19 PM

I believe F16 still uses grub1? In which case, you would edit /boot/grub/menu.lst and remove the option on the kernel line.

rpcaldeira 12-06-2011 03:21 PM

nope, the file is empty, and there is a /boot/grub2 folder in there

adamk75 12-06-2011 03:26 PM

Sorry, I don't know how to do it with grub2.


rpcaldeira 12-06-2011 03:30 PM

ok, anyway you have been the most helpful you could get. Thank You Seriously!!!

My greatest regards ;)

rpcaldeira 12-06-2011 03:36 PM

Just in case you are wondering, you just have to edit the /boot/grub2/grub.cfg file, and it's off the the races, thanks again ;)

Lsatenstein 12-07-2011 08:08 AM

I have a bout of impatience. I cannot spend long times with grub2 and the multitude of directories that hold configuration scripts.

What I do is as follows:

I edit the grub2/grub.cfg file to what I want.
I save it
I save it again as grub.bak

Since this is a personal fedora, when a new kernel arrives, I look at the grub.bak against the grub2, and bring back the changes.
Normally this latter action takes about 5 minutes.

I guess some weekend when I have time, I will learn more about grub2 and the use of each subdirectory in the *.d

I guess some developers never heard of or followed the KISS principal.

ALTN 04-17-2012 09:42 AM

hi folks,

I'm having the same problem as rpcaldeira, i have an ASUS-N55DF laptop and i'm trying to install fedora 16 on it but with no success.

I tried openSUSE before it with no success, tried also ubuntu 12.04 and it worked but wasn't comfortable for me with java development.

i saw that rpcaldeira succeeded in installing F16, and i will be grateful if i get any help.

i followed this link, for installing fedora alongside with windows 7, i set the nomodeset option on startup, and i'm using a bootable usb stick.

As soon as the desktop loads, a window pops up saying


GNOME 3 Failed to Load
Unfortunately GNOME 3 failed to start properly and started in the fallback mode.

This most likely means your system (graphics hardware or driver) is not capable of delivering the full GNOME 3 experience.

i closed it and followed the instructions, when i reached the partitioning phase, i got an unhandled exception : "an unhandled exception has occured. This is most likely a bug. Please save a copy of the detailed exception and file a bug report", the log file is in this link!download|70...44|log.txt|521 (couldn't directly attach it because its size exceeds the limits of the forum).

this is the output of fdisk -l:

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xa383324b

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1            2048    52430847    26214400  1c  Hidden W95 FAT32 (LBA)
/dev/sda2  *    52430848  400738303  174153728    7  HPFS/NTFS/exFAT
/dev/sda3      400738304  1255428095  427344896    7  HPFS/NTFS/exFAT
/dev/sda4      1255430142  1465147391  104858625    5  Extended
Partition 4 does not start on physical sector boundary.

Disk /dev/sdb: 8011 MB, 8011120640 bytes
247 heads, 62 sectors/track, 1021 cylinders, total 15646720 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x20ac7dda

This doesn't look like a partition table
Probably you selected the wrong device.

  Device Boot      Start        End      Blocks  Id  System
/dev/sdb1  ?  3224498923  3657370039  216435558+  7  HPFS/NTFS/exFAT
/dev/sdb2  ?  3272020941  930513678  976730017  16  Hidden FAT16
/dev/sdb3  ?          0          0          0  6f  Unknown
/dev/sdb4        50200576  974536369  462167897    0  Empty

Partition table entries are not in disk order

Disk /dev/mapper/live-rw: 4294 MB, 4294967296 bytes
255 heads, 63 sectors/track, 522 cylinders, total 8388608 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/live-rw doesn't contain a valid partition table

Disk /dev/mapper/live-osimg-min: 4294 MB, 4294967296 bytes
255 heads, 63 sectors/track, 522 cylinders, total 8388608 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/live-osimg-min doesn't contain a valid partition table

in summary:
sda1 fat32 recovery_partition 25GB
sda2 ntfs Windows 7 system partition 166GB
sda3 ntfs DATA partition 407GB
sda4 extended unallocated 100GB
sdb* refers normally to the usb stick

i'm trying to install F16 into sda4

NB: i installed Fedora 16 into another old machine, with the same partioning structure (but with no recovery) and of course with no nomodeset and it worked with no problem, but i need to install it in my ASUS N55SF.

any help will be appreciated.

ALTN 04-17-2012 10:14 AM

i think the problem is that i'm trying to install fedora into an extended partition sda4.
sda1, sda2 and sda3 are primary, i'll try to transform sda3 to an extended - retry installing into a primary partition - then report the results.

All times are GMT -5. The time now is 01:27 AM.