LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-14-2004, 08:57 AM   #1
seb3579
LQ Newbie
 
Registered: May 2004
Posts: 13

Rep: Reputation: 0
[Audio] Cant open device (permissions)


Whenever i log in, i get the following message:

******
Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (Permission denied)
The sound server will continue, using the null output device.
******

I have tried to change the permissions of /dev/dsp, by
chmod 777 /dev/dsp as root, and this is only a temporary solution. It gives me the same problem everytime i log in.
I run MDK 10.0 official (2.6.3-7mdk), and i used to have audio output - but i lost it when i upgraded to KDE 3.2.2.

Any help much appreciated!

Seb
 
Old 05-14-2004, 10:21 AM   #2
Inhibit
Member
 
Registered: Apr 2004
Distribution: Mandrake, Gentoo, SuSe, JDS
Posts: 53

Rep: Reputation: 15
The two problems that come to mind would be PAM authentication (/etc/security/console.perms) and the DevFS (/etc/devfsd.conf) setup. Also, there's an audio group in Mandrake that you might need to add your user to.. check if the /dev/dsp device gives the correct permission for r/w to it's group (i.e. rw-rw---- root audio) and add the user into that group if it does. Also, what is the /dev/dsp device set to after you log in?

Mandrake changes around permissions on log-in for a few things, which can be a real headache.
 
Old 05-14-2004, 10:51 AM   #3
LavaDevil94
LQ Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 47
Try adding your user to the 'audio' group.
 
Old 05-15-2004, 12:24 AM   #4
seb3579
LQ Newbie
 
Registered: May 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by LavaDevil94
Try adding your user to the 'audio' group.
I have, yet this does nothing...

I have played around with /etc/security/console.perms but i have had no success what so ever in getting audio without manually changing permissions everytime i log in.

Please remember that my problem only started happening when i upgraded to kde 3.2.2. Previous to the installation, my audio was fine.

I tried to add another user, and when i logged in as that user - audio worked. They were not part of the audio group, and everything was standard. however, now when i log in - no audio...

Any help is much appreciated.

Seb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot open audio device deus_machinarum SUSE / openSUSE 8 06-20-2005 05:44 PM
audio device fails to open on arch linux, even after alsa config sether Linux - Hardware 1 10-07-2004 01:43 AM
Configuring audio, video and device permissions intersidereal Slackware 1 07-02-2004 03:38 PM
XMMS problem : ** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): sureshrk19 Slackware 4 04-01-2004 10:17 PM
ogg123 can't open audio device oot Linux - Newbie 2 05-21-2003 06:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration