-   Linux - General (
-   -   Xubuntu 13.04 Logs Out Randomly with Enter Key (

derekpock 05-01-2013 05:41 PM

Xubuntu 13.04 Logs Out Randomly with Enter Key
Xubuntu 13.04 - Samsung RV510
4Gs - 512 SSD - Dual Boot Win 7

Xubuntu tends to randomly log me out at random times. It only happens, however, when I press the enter key at any time. I notice it more when I am working on a terminal, but it happens anywhere. All jobs are still running, however, because I was running a gparted resize when it happened last, but the resize was still going after logout and login.

273 05-02-2013 04:05 AM

You could be catching a key combination that is set up to lock the machine. I see that F12 is set to lock the machine in combination with the Fn key under Windows -- perhaps it has something to do with this, is the Fn key becoming stuck down and you are catching F12 for example?
Is there an icon on your panel for locking, or shutting down the machine? If so, could you be catching the touchpad whilst typing with the mouse pointer hovering over this?

derekpock 05-02-2013 01:06 PM

No, there are no key combinations as such that force logout. Only at random times with only the enter key. Fn+F12 does not logout. There is a lock on my panel, but it locks it to XScreenSaver, not a complete logout. This may be a Bug. I also have syndaemon working to delay touchpad for .5 seconds after keyboard use, so nothing with the mouse. Specifically with the ENTER.

charly_k_w 05-08-2013 04:20 AM

same problem here

After I start up the system it does autologin and will also autostart at least 3 programs, 1 instance of Skype and 2 empty Document viewer windows. If I delete those Document viewers it will automatically log me off and after entering the password come back again with those 3 autostarted windows.
And it will also log off, if i attempt to start claws-mail.

If I leave them alone and work only on workspace 2 (in order not be be annoyed by seeing them all the time) the system runs stable for days. For a big internal backup session over network i had it running 48 hours last week.

right now i use this system for firefox, file manager and vlc. All applications that I need to run uninterupted, like chats and mail i run on one of my raspberry pi

intel i3, nvidia GT9600 with dual display, second OS via GRUB Windows XP

derekpock 05-08-2013 07:23 PM

After updating. I have not experienced this problem again. Hopefully it never returns! Suggest updating and if you have broken dependencies, remove them from your ppa source codes.

charly_k_w 05-09-2013 12:55 AM

I upgraded to 13.04 only one week ago and ran every suggested update since.
But this morning something else happened: yesterday I managed to get rid of those two Document viewer windows, don't know exactly how, but i think i closed them and from the automatically invoced login screen i then shutdown the system without login in again. And today I was finally able to start claws mail with no problems this time.
So I'm going to watch and see whether that was the trouble maker here.

memilanuk 05-25-2013 10:53 PM

Hello there,

I've got nearly the same thing going on here... fresh install of Xubuntu 13.04 that was working fine until a few days ago; now it randomly logs me out after I try closing all the windows that were open the last time it kicked me out. Sometimes I'll get those all closed, and then about five seconds later it just dumps me back to the login window; other times I might make it far enough to try and *manually* logout or shutdown or open a window to configure session startup options, but as soon as I do, I get logged out again.

It was working fine, up until a couple days ago... about when I applied the most recent batch(es) of updates.

Same machine (Lenovo T530) dual-boots back into Win7Pro with no issues, and I've spent a fair amount of time running MemTest so I don't think its the hardware itself.

Any ideas? I can get to the console via Ctrl+Alt+F1 and look at the log files, but not sure what I'm looking for in this instance.



charly_k_w 05-26-2013 04:13 AM

after my last post above within one day the problems reapeared! But since the updates to the system yesterday, may 25th, to kernel .22 they seem to have been resolved for good. I'm just now running applications that were on start causing the logout problem, e.g. Gooogle Earth, and now they work.

charly_k_w 05-26-2013 05:12 AM

Sorry for the previous success message, now after about 3 hrs running on the new kernel the problem is back

derekpock 05-26-2013 09:41 AM

Could anybody/everyone that has this problem please give me the output of this command:


ls /etc/apt/sources.list.d; echo; cat /etc/apt/sources.list
and also


sudo apt-get update -qq
I fixed mine, no longer any problems with the enter key, I may be able to help.


charly_k_w 05-26-2013 11:36 AM

thanks for trying to help, derek. Here the lists, to make it a bit shorter I took out the commented lines. First the /etc/apt/sources listings:

google-earth.list medibuntu.list
google-earth.list.distUpgrade medibuntu.list.distUpgrade

deb raring main restricted
deb-src raring main restricted

deb raring-updates main restricted
deb-src raring-updates main restricted

deb raring universe
deb-src raring universe
deb raring-updates universe
deb-src raring-updates universe

deb raring multiverse
deb-src raring multiverse
deb raring-updates multiverse
deb-src raring-updates multiverse

deb raring-backports main restricted universe
deb-src raring-backports main restricted universe

deb raring-security main restricted
deb-src raring-security main restricted
deb raring-security universe
deb-src raring-security universe
deb raring-security multiverse
deb-src raring-security multiverse

deb raring partner
deb-src raring partner

deb raring main
deb-src raring main

about the apt-get command: option -qq is explicitly discouraged in the man pages, for unforseeable results?

derekpock 05-26-2013 04:47 PM

The option -qq posts only errors, I wanted to know what kind/if you had any errors when looking at updates.
Another code run again, this may provide more info for me.


cat /etc/apt/sources.list.d/*;

Also, what program(s) is/are register/used for the ppa jonoomph-openshot-edge-quantal.list?

memilanuk 05-26-2013 11:33 PM

I think the problem is this:

I applied the fix from the ppa mentioned in comment #19 and it seems to have remedied the problem (for now).

The question running thru my mind is... this bug was filed on 1/24... its now Memorial Day weekend... four months later... and there still isn't an 'official' patch or fix. Whiskey Tango Foxtrot...?

charly_k_w 05-27-2013 10:14 AM

I now installed the patch that memilanuk described and for 10 minutes now the system is running stable :-)
Thanks to everybody who tried to help. The real difficulty with this bug is the variety of actions that might or might not trigger it. It also made the wording to search for a already filed bug report very complicated.
Anyway it seems to work now, and if not, this morning I installed an additional HDD and will install Knoppix on it after the next crash.

All times are GMT -5. The time now is 05:47 AM.