-   Linux - General (
-   -   xterm will not produce output with -lf parameter (

jarobman 03-01-2005 04:54 AM

xterm will not produce output with -lf parameter
xterm will not produce an output file of any of its sessions even if I specify the -lf parameter. I have no idea why it is behaving like this. The reason I need xterm to produce output to a file is because a program I am using, BSVC 68000 Simulator, opens up xterm and spits out any 68000 simulated output to the terminal. The setup file for BSVC specifies that xterm be called in a certain way:

BSVC Simulator Setup File

SIMULATOR {sim68000}
COMMAND {AttachDevice 0 RAM {BaseAddress = 0 Size = 100000}}
COMMAND {AttachDevice 0 M68681 {BaseAddress = effc00 OffsetToFirstRegister = 1 OffsetBetweenRegisters = 2 InterruptLevel = 4 PortAStandardInputOutputFlag = 0 PortBStandardInputOutputFlag = 0 PortACommand = xterm -T "M68681 Port A" -132 -sb -sl 100 -l -lf "68kout.txt" -e xtermpipe PortBCommand = }}

I have tried messing around with the setup file to see some results but was unsuccessful. I have even tried running xterm independenly from konsole and still no output. If anyone can give me some insight on how to get output from xterm that would be great because I need BSVC for a course in assembly language. Thanks in advance!

Tinkster 03-02-2005 03:03 PM

You may have to recompile xterm ... most distro's will have
recording NOT compiled in for security reason.

Alternatively you can try to use script (man script for details)
to capture the session ...


jarobman 03-06-2005 03:12 AM

Thanks for the tip! I'll try and find a way to recompile xterm. FYI, script will not work for me as it appears that it cannot capture an xterm session that specifies -e xtermpipe as a parameter. This parameter is required for BSVC to display its output via xterm.

On a side note, I may not want to recompile xterm to log console output because I read that there is a security leak with respect to logging that allows any user to gain access to the root user... a very good reason to disable logging by default;)

All times are GMT -5. The time now is 03:02 PM.