-   Linux - General (
-   -   Xorg, no screens found; no devices found (after Virtualbox install) (

Archytas 07-30-2011 03:52 PM

Xorg, no screens found; no devices found (after Virtualbox install)
When I boot my Fedora 15 installation it shows me the blue screen with progress indicator, however I do not reach the login screen.
Instead I see the textual shell where the last item is:

Started Display Manager.

It looks like my monitors are not detected anymore. I have been working with them though (this appeared after a restart).

In /var/log/Xorg.0.log
I see lines like:
[35.734] (EE) no devices detected.
Fatal server error:
[35.734] no screens found

One thing I have done during last succesful session was the installation of VirtualBox, so maybe that this interferes with it in some manner.

I have no idea how to solve this. What should I change to make gnome3 find my displays once again. If you need any info please ask.

Much thanks in advance.

Some additional details:

I have a dual monitor set up with a
Samsung SyncMaster 710T via VGA and a
Samsung SyncMaster 2443 via HDMI
connected to a
MSI RS450 MD512H video card (problem still exists after removing the video card and using internal graphics).

I am not sure how I determined it but I read in some log that no display was detected. Nothing changed to the hardware set up however.

I see some suggestions to run system-config-display as root.
However this command can not be found nor can it be found when I run yum install system-config-display.



Archytas 07-30-2011 07:15 PM

Any suggestions yet?
The live distro is able to recognize my screens, is there a way to make Fedora do the recognition of the screens once again, or can I copy some config from the live distro?

frankbell 07-30-2011 09:22 PM

Just to be clear, is it Fedora 15 in VirtualBox that is hosed or is your entire system hosed after doing a VirtualBox install?

If the former, what are the display settings in the configuration for your virtual machine?

Archytas 07-30-2011 09:53 PM

Hi Frankbell,

Its the latter. I haven't been trying to run Linux in Virtualbox yet. I can not get into the login screen (of gnome3 I believe) of my main install.

Archytas 08-03-2011 11:20 PM

I tried to create a 10-monitor.conf which also did not succeed.

After spending some days on the issue I backed up my user data, reinstalled FC15 and started installing the software once again. Both time consuming but at least it gives me some results (no black screens to watch).

If anyone would still come up with a solution, I might be able to boot into the old installation since I didn't throw the old partitions.

Roops 06-16-2012 11:50 PM

Worked for me
I have a centos 6.2 installation too.Recently i was facing the same problem and i figured out that the display is using /etc/X11/xorg.conf to detect the monitor. This file is created by virtualbox after using sudo /etc/init.d/vboxdrv setup command.Now somehow the centos is also trying to lode it while initializing the display.

I just renamed the /etc/X11/xorg.conf file for stopping centos to use it by issuing:

# mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

And it works....

Hope It Might be help full For anybody.:-)

isptrader 03-06-2013 03:41 PM

This worked for Fedora 18 upgrade from Fedora 17 under Virtualbox too.

All times are GMT -5. The time now is 09:35 PM.