-   Linux - General (
-   -   Xorg memory usage (leak) (

ideasman 08-09-2007 06:44 PM

Xorg memory usage (leak)
Hi, Iv been having a problem with my Xorg 7.2's memory usage.
It seems to be leaking ram.

When I start X it uses about 45meg of ram. but at one point X was using ~840 meg of ram - after closing everything except the window manager and a terminal.
. so I decieded to find out where it was going.

I read up and aparently 'pmap pid' is a good way to tell whats using your ram.

so I tried this only to find out that around 800meg was used by [ anon ]...

At the time of writing it looks like this)

- from top
1066 root 14 -1 341m 288m 9316 S 2 14.5 77:14.40 X

- the guys on #xorg told me to try xrestop, but it does not report on the big chunkl of 'anon' memory.
xrestop - Display: localhost:0
Monitoring 18 clients. XErrors: 0
Pixmaps: 78303K total, Other: 350K total, All: 78654K total

# pmap 1066
08048000 1224K r-x-- /usr/X11R7/bin/Xorg
0817a000 52K rw--- /usr/X11R7/bin/Xorg
08187000 267188K rw--- [ anon ]
ae918000 8200K rw--- [ anon ]
afc1e000 1380K rw-s- /dev/nvidia1
b025e000 1380K rw-s- /dev/nvidia1

This is using more memory then all other map's put together.
267188K rw--- [ anon ]

Apps Im running that could cause this are... Mesa-7.0 for OpenGL, eclipse, NVidia's drivers. Multiple monitors.... Linux version, glibc-2.6.1

But all this is closed when I check and tried restarting my window manager also, so Im not sure whats leaking the memory. Restarting X goes back to 45meg of ram again and then slowly rises. Iv kept 'top' open to see if the memory jumped at any time. but it was just a gradual leak from what I could see.

I talked to another person on #xorg who had the same problem, he was running fluxbox...

So my question is, has anyone experienced this problem before? and is there a way to find what "[ anon ]" is being used by?

ideasman 08-09-2007 08:14 PM

looks like its fixed in teh development tree since fixes have been backported.

All times are GMT -5. The time now is 05:50 AM.