-   Linux - General (
-   -   .xinitrc fluxbox question (

Abe_the_Man 01-02-2004 11:17 AM

.xinitrc fluxbox question
I want to make gkrellm start in the fluxbox slit on startup, everywhere i've read it says you add the app names to your ~/.xinitrc. Only problem is that my user account has no .xinitrc. I coppied the one from the root account , but it was for windowmaker, so i changed the last line to say fluxbox instead and added gkrellm -w to the line above.

# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $


# merge in defaults and keymaps

if [ -f $sysresources ]; then
xrdb -merge $sysresources

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap

if [ -f $userresources ]; then
xrdb -merge $userresources

if [ -f $usermodmap ]; then
xmodmap $usermodmap

# If the user lacks $HOME/GNUstep, install it:
if [ ! -f $HOME/GNUstep/Defaults/WindowMaker ]; then

# Test for cpp, which wmaker uses to process config files:
if [ ! -x /usr/bin/cpp ]; then

gkrellm -w

# Start the window manager:
exec fluxbox

I have no idea what i'm doing as i've only ever run just plane gnome before. So please be gentle.

luxitan 01-02-2004 11:27 AM

i changed my /etc/X11/XSession to load all progs before calling fluxbox
this assuming you use gdm, if you use another graphical login the process should be similar

AxeZ 01-02-2004 03:30 PM

jesus...just create file .xinitrc in your home dir with one line ( well, two ).

exec fluxbox

save it and make it executable

Abe_the_Man 01-03-2004 12:24 AM


Originally posted by AxeZ
jesus...just create file .xinitrc in your home dir with one line ( well, two ).

exec fluxbox

save it and make it executable

oh..... right on. Thanks both of you.

mikshaw 01-03-2004 12:30 AM

You did fine doing what you did...nothing wrong with that.

Another option, if you're running Fluxbox 0.9.6, is to use the ~/.fluxbox/apps file. In this you can specify programs to start only in fluxbox, but not in other window managers.

BroX 01-08-2004 04:45 AM

-jesus...just create file .xinitrc in your home dir with one line ( well, two ).
-exec fluxbox
-save it and make it executable

I read this thread with great interest since I also want to startup some apps while using fluxbox. However, whatever suggestion I follow, nothing seems to happen. Is there a way to check whether my .xsession is actually accessed?

And another thing: to test it, do I have to reboot, or is log off/on enough?

Thanks, Leon.

Abe_the_Man 01-08-2004 11:31 AM

i figured it out LJSBrokken! just create the file /home/youruser/.fluxbox/apps and add whatever programs you want. I run gkrellm and fbdesk at startup so i just use this

[startup] {gkrellm -w}
[startup] {fbdesk}

just change it to programs you want.

BroX 01-09-2004 02:22 AM

Abe I thought you relieved me from this annoying thing, but also this doesn't work for me. I must be doing something completely wrong?!
I wish I could give more details but I have no clue which. I have tried adding the startup progs to .xinitrc, .xsession, and now this apps file.

About apps: doesn't fluxbox have to know somehow that it should look in that file? I added the line session.appsFile: ~/.fluxbox/apps to the ~/.fluxbox/init file, but no luck with that either.

Anyone, anything?

mikshaw 01-09-2004 02:33 AM

apps is a new addition....if you're using Fluxbox stable it's not available.

BroX 01-09-2004 02:48 AM

Thanx mikshaw, that explains it :-(

Is there a way to 'upgrade' to the latest development version? Or should I first get rid of the stable version and than compile the new one?

But anyway, does anyone have an idea why making a .xsession file does not seem to have any effect?

RaulConQ 04-28-2004 07:06 PM

Re: upgrading to development version, Slack 9.1 comes with the stable, but I just did the standard ./configure, make, make install on fluxbox 0.9.9 and it works fine. I don't know if 0.1.14 is still hanging around somewhere, but I'll deal with it later... still tweaking my slit... for some reason, it doesn't load the apps in the order that I want... *grumble*

|2ainman 04-28-2004 11:05 PM

I'm pretty sure that the reason .xinitrc does not work for you, is that your using a graphical login such as kdm or gdm. The .xinitrc works only when u start in runlevel 3, then type startx.

spooge 06-19-2004 06:50 PM


The .xinitrc works only when u start in runlevel 3, then type startx.
just stmbled on this...

so how does one get this(/home/.jerkface/.xinitrc) to load at kdm or gdm
or should i say the executions within /home/.jerkface/.xinitrc) at kdm or gdm

thanks !!
slackin and fluxin !

Ninaw 06-28-2004 07:25 AM

i had this problem before and then discovered that the culprit is.....the ampersand!!
it seems you need to add an ampersand ( & ) at the end of additional programs you want to run

here's my .xinitrc file


exec wmxmms &
exec wmcpuload &
exec wmupmon &
exec gaim &
exec fluxbox

All times are GMT -5. The time now is 01:59 AM.