LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-26-2004, 05:00 PM   #1
nifflerX
Member
 
Registered: Dec 2003
Distribution: RedHat 8.0, 7.1 and Enterprise WS 3,4
Posts: 94

Rep: Reputation: 16
Xfree86 4.3 on redhat 8.0


Hi,

I've currently have redhat 8.0 with XFree86 version 4.2.1 running. I'd like to update to version 4.3 of XFree86. I downloaded the binaries from the xfree website "www_xfree_org" (sorry, but I can't post URLs yet) and ran their Xinstall.sh script from a terminal without running X. I downloaded the binaries for glibc22 which I am pretty certain are the correct ones. Then I restarted the X-server and that's where my problems would start.

My machine would still work, it's that all the nice desktop managers (kde, and Gnome) were gone. I was given a very basic looking login window (which worked). And then my desktop manager was incredibly basic, no taskbar at the bottom, no nothing. Not even a good way to bring up a 2nd terminal window.

I then replaced /etc/X11, /etc/fonts, and /usr/X11R6 with the backups I had made before starting this whole process and I was back to normal. I was wondering if what files do I need to move from my backups to my new installation to allow my new installation to see all the desktop managers? Thanks so much.


-NifflerX
 
Old 02-26-2004, 05:43 PM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Try running switchdesk.

You should be able to configure it that way, if not let us know. There are config files that can be changed to do it.
 
Old 02-27-2004, 09:27 AM   #3
nifflerX
Member
 
Registered: Dec 2003
Distribution: RedHat 8.0, 7.1 and Enterprise WS 3,4
Posts: 94

Original Poster
Rep: Reputation: 16
Hi, thanks for the reply. I tried switchdesk, and it ran and told me to restart my Xwindows to have the changes take place, but after restarting my Xwindows there were no changes. You said something about moving certain configuration files from my backup folders to my newly installed ones. Which ones did you have in mind? Thanks so much.



-NifflerX
 
Old 02-27-2004, 01:18 PM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
The xinitrc file is normally used to start the window manager.

search for xinitrc like this

locate xinitrc

you can also put your own .xinitrc in your home folder if you want.

you may also have an Xclients file that will be used as a first choice by the xinitrc file.

locate Xclients

looking at the xinitrc file in /etc/X11/xinit/ will show you how it works. It sounds like you are defaulting to the failsafe setting which is what happens if no .Xclients file is found.


you can change twm in the file to the window manager you want like "startkde" or "gnome-session"
 
Old 02-27-2004, 01:48 PM   #5
nifflerX
Member
 
Registered: Dec 2003
Distribution: RedHat 8.0, 7.1 and Enterprise WS 3,4
Posts: 94

Original Poster
Rep: Reputation: 16
I tried substituting the files you suggested but it didn't work. I did run startkde and it opened a desktop that looked like the one I want but it was running inside a shell not as the actual desktop. One problem I think is that I can tell when I've got the newer version of XFree86 installed before I log in. My log in window looks very boxy and basic, and the background, instead of being blue is a gray. So I believe the problems occur before I even log in. Also, regardless of which session I choose from the pull down menu (gnome, failsafe, default, and kde) I get the same boxy basic desktop. Have I not configured something right from the beginning? Is that why my log in window looks so bad? Thanks for any and all ideas.


-NifflerX
 
Old 02-27-2004, 07:15 PM   #6
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
check out /etc/sysconfig/desktop

that should set the default WM which will determine which login manager you get according to the /etc/X11/prefdm file that should have been called by /etc/inittab on boot or during a runlevel change to level 5
 
Old 02-27-2004, 07:25 PM   #7
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
You can try this test to see what you get..

from terminal as root run this..

init 3

then as the user create a file /home/user/.xinitrc containing this..

exec startkde


now as the user run this..

xinit
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to used 'redhat-config-xfree86' clemensryane Red Hat 3 10-09-2004 08:15 AM
Problems with Redhat 9 XFree86 lichung Linux - Newbie 4 08-04-2003 11:32 AM
Installing Xfree86 4.3.0 on RedHat 8.0 sardaukar_siet Linux - Software 1 03-14-2003 10:33 AM
XFree86 Error on RedHat 8.0 Gagan Linux - Newbie 1 11-18-2002 07:28 AM
Upgrading XFree86 to 4.1 in Redhat 7.2 ChaNce Linux - Software 1 11-12-2001 06:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration