-   Linux - General (
-   -   xfce4 icons are dead. (either "X" or nothing) (

kaz2100 02-20-2007 05:45 PM

xfce4 icons are dead. (either "X" or nothing)

I have Debian etch with xfce4.

Problem is: #1, Icons on desktop all turned into red "X" on portrait while rectangle.
#2, Desktop image does not show. (file exists and not dead, gimp can see it)
#3. Icons on panels, menu and setting manager are all gone, except for screensaver.
#4. Splash screen (Balou) is not working. (simple and mice look ok)

These happened 2 days ago.

Most suspicious thing I did was "aptitude update/upgrade" so I reinstalled following packages

dbus-1-utils desktop-base desktop-file-utils fortune-mod fortunes-min
gamin hal libavcodec0d libdbus-glib-1-2 libexo-0.3-0 libgamin0 libgsm1
libhal-storage1 libhal1 libmodplug0c2 libpostproc0d librecode0 libspeex1
libtag1c2a libtagc0 libtheora0 libthunar-vfs-1-2 libvte-common libvte4
libxine1 libxvmc1 mousepad orage pmount shared-mime-info thunar xbitmaps
xfce4-mixer xfce4-mixer-alsa xfce4-panel xfce4-session xfce4-terminal
xfce4-utils xfdesktop4 xfmedia xfprint4 xterm xfce4

These are the packages which would be removed if I did 'aptitude purge xfce4'.

Still problem exists. Other xfce4 functions seem to be ok.

One thing I do not quite understand is that my other penguin, (Debian etch) which I also aptitude update/upgrade almost same time, is perfectly fine.

What can I do to resolve this? Is there any logs for xfce4?

Any suggestion and input will be appreciated.

Happy Penguins!

kaz2100 02-22-2007 02:04 PM




Problem was broken package (libgtk2.0-0).

This is whatever I did.

Thunar did not work.
I tried to open from xterm, thunar complained that failed to load fallback icon from /what/ever/file.png. (this file exists and correct format and display can open it.)
Reinstall of libpng did not change anything.
I checked dependency and tried one by one (my guess was most probably file access or graphic related).
When I reinstalled libgtk2.0-0, BINGO!

One page in Debian says something different....

Happy Penguins!

All times are GMT -5. The time now is 11:06 PM.