-   Linux - General (
-   -   X Is Broken (

carlosinfl 07-23-2006 02:25 PM

X Is Broken
OK - I installed Linux (Debian) which installed Gnome 2.14 by default however came with a vanilla kernel. I then upgraded the kernel to the linux-image-2.6.16-2-686. After I installed the latest kernel for my P4 1.6GHz CPU, I reboot into the newly installed kernel and then X no longer works.

The xorg.conf file is using the default "nv" driver but this stops working when I use the new kernel. I really don't know what to do to fix this? How do I get GDM started / working again? There is not error message that comes up except that X is not configured correctly and for now it will disable X untill the issue has been resolved.

Anyone have any suggestions?

raskin 07-23-2006 02:53 PM

Yes. You use proprietary nVidia drivers (did you try for free software 3D drivers? which need proprietary nVidia kernel modules (well, all methods of getting 3D acceleration in Linux require some kernel module). Surely they are a bit different for every kernel. You can get (as I understand) something more close to universal, which will let you to compile kernel-dependent stuff (until API changes too much).

carlosinfl 07-23-2006 03:34 PM

Yes, even after I install the Nvidia drivers for Linux and then make sure the driver is then correctly set to "nvidia", it stil bicthes about my config not working...

raskin 07-23-2006 03:46 PM

Well, do you have kernel module for nvidia?

carlosinfl 07-23-2006 05:18 PM

I assume it built/created one during the Nvidia driver install. Why?

Matir 07-23-2006 06:40 PM

What error message does it give you?

carlosinfl 07-24-2006 09:13 AM

OK - I have seen this problem with Debian before. I installed Etch on a system and then I loaded the 2.6.16-2-686 kernel however X fails because Debian can not find a module for my USB optical mouse there for it fails to load X. I know that if I add the module for the mouse, the issue will be resolved however I have not done this personally. I really don't know where to begin. When I view my /etc/modules file, I see the following:


# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


I tried even adding "usbmouse" in there and restarting with still no success. Anyone care to help me get this working... :cry:

Matir 07-24-2006 09:15 AM

Make sure your X config points to /dev/input/mice for your mouse. This is a central connection for basically all the kernel-level mouse drivers.

All times are GMT -5. The time now is 12:20 PM.