-   Linux - General (
-   -   X include files (

evian 03-25-2003 01:59 PM

X include files

I have tried to install some programs and I keep getting this error message and I don't know how to fix it:

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!ow how to fix it:

I am using RedHat 8, is there a configuration i need to change somewhere?


tcaptain 03-25-2003 02:10 PM

this is a shot in the dark but check the file (or conf...I can't remember off hand) in the /etc directory to see if it has an entry for those directories...

Also, do you have the -devel files installed? (that might be it too maybe? Not sure).

evian 03-25-2003 02:14 PM

does this entry mean these files are included?:


>Also, do you have the -devel files installed? (that might be it too maybe? Not sure).

I am not sure what -devel files are. So this could very well be the problem


david_ross 03-25-2003 02:22 PM

I think you may need to install the development rpms. Run:
"rpm -qa | grep XFree86-devel"
to see if it is already installed.

Personally I would try to find an rpm version first - it will install much easier. (take a look at

tcaptain 03-25-2003 02:25 PM

by -devel I mean the development packages. I'm not familiar with RH8 unfortunately so I can't tell you if they get installed by default, maybe someone will jump in here.

As for what you saw...yeah, that's supposed to be there, which means that X libraries would be found (I think).

Also, can you post what software is giving you problems?

I've come a long way since my first linux distro (Mandrake 7.0) but I'm still very much a newbie...

david_ross 03-25-2003 02:40 PM

if it is not installed download:

Then install it using:
rpm -ivh /path/to/XFree86-devel-4.2.0-72.i386.rpm

evian 03-25-2003 04:53 PM

i think that fixed it, thanks allot

All times are GMT -5. The time now is 08:46 PM.