-   Linux - General (
-   -   X doesnt start anymore; error message: "/etc/X11/ X is not an executable" (

lixy 01-13-2006 06:06 AM

X doesnt start anymore; error message: "/etc/X11/ X is not an executable"
Hi all,

Having upgraded Gnome from the experimental repository, I have been asked several time by module-assistant whether i wanted to use XFree86 or Xorg. Having always tweaked with the XF68Config-4, I guessed I should choose XFree86. Now, upon reboot X refuses to start on account that /etc/X11/ X is not an executable.
I have no idea what this file should be or why it was created along with a Xorg.conf file which replicated my XF68Config-4. dpkg-reconfigure xserver-xfree86 doesn't execute the wizard as expected to. I even tried deleting the new files (i.e: X and Xorg.conf) but the issue persisted. I am using Debian Sid with Nvidia's drivers and tried upgrading Gnome 2.10 to 2.12.
Any hints will be more than welcome.

Thanks in advance.

lixy 01-13-2006 06:37 AM

Sorry people, in my panic I didn't do the homework. It seems Debian unstable lost xfree86 for xorg
. Doesn't explain why I was asked if I wanted to use either of them as the former was removed.
Now dpkg-reconfigure xserver-xorg, goes just fine, up until restarting gdm again. I get the Nvidia splash screen but it fails loading gnome. But that's another issue, I guess. Thanks anyway.

lixy 01-13-2006 12:18 PM

Don't bother. I did a clean install of Ubuntu.

Vgui 01-13-2006 08:20 PM

Either way, for future reference the answer to this problem would have likely been:

chmod +x /etc/X11/X
It will just make the X binary executable again (and likely has to be done as root). I imagine the updating of your XFree / install messed up the permissions somewhere along the line.

lixy 01-14-2006 09:09 AM

Thanks for the interest! Rendering it executable was the trivial thing to do. I'm sorry I didn't mention I tried it before posting. The thing is, X is supposed to be a link to X -> /usr/bin/X11/Xorg. Something must have been broken in Xorg.

Vgui 01-14-2006 09:12 AM

So I assume you made the Xorg binary executable as well, and the problem still persisted? Or maybe startx wasn't executable...the whole X startup process is a little busy.

All times are GMT -5. The time now is 03:15 PM.