-   Linux - General (
-   -   Windows XP installation problem over Fedora 13 (

lilpirate 08-17-2010 04:42 AM

Windows XP installation problem over Fedora 13

First of all, I'd like to tell you that I had installed Windows 7 (clean) on my new computer. Then, I installed Fedora 13 64-bit. Eventually, I wanted to install Windows XP, so, formatted the drive (NTFS) which had Windows 7. Now, I have Fedora 13 running good. But, now, when I'm trying to install Windows XP I'm getting different errors. At first, it was - "A disk read error has occurred. Press Ctrl+Alt+Delete to restart".

I took a MS-DOS 6 CD and booted up. Ran chkdsk, but it checked only my CD-Drive. Nothing else. When I tried to run fdisk and looked for existing paritions, it showed me nothing inspite of having 6 partitions on my 1TB HDD.

One of it is ext4 (Fedora), swap and others are FAT and NTFS.

Now, after running chkdsk, when I tried to install XP, I get an error - Error loading operating system.

I googled, and found this - And I'm pretty sure that my issue is "Cause" (as on the page) #3, that is -

Issue with drive's partitions.
And it the solution is suggests is -


This issue can be cause if the disk drives are not properly setup or have been changed by another program, such as a utility that comes with a Linux distribution. To resolve this issue, delete and recreate all the partitions before running the Windows XP setup.
I don't want to delete and recreate all the partitions :(

I've well setup-ed Fedora installation. Does anybody know a solution?


dr_agon 08-17-2010 08:11 AM

I'm not sure at what stage of installation you got the error - does XP installer load properly, giving you an (empty) choice of possible partitions? If not, check the installation CD for errors.

Run fdisk from Fedora (as root) like this:

fdisk -l /dev/sda
(replace /dev/sda with your harddisk device name)
and show us what partitions you really have.

Rearrange partitions to have one primary partition for your WinXP installation, which can be marked active (bootable). Use any tool from Fedora.

Remember, that after installation of Windows the bootloader in MBR will be overwritten, so you will have to restore your Fedora bootloader later.

lilpirate 08-17-2010 08:27 AM

Thanks for the reply, dr_agon.

I finally managed to install XP. But now, after getting back the GRUB, I am again getting the error - "A disk read error has occurred. Press Ctrl+Alt+Delete to restart" when tried to load XP from GRUB.

Is there any way I can get back the Windows Boot Loader menu and have Fedora in it?


here's the output of "fdisk -l /dev/sda"


Warning: ignoring extra data in partition table 5
omitting empty partition (6)

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x45cb049e

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 102400 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 14 12749 102293604 7 HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sda3 12749 25229 100249600 83 Linux
Partition 3 does not end on cylinder boundary.
/dev/sda4 25229 121602 774111232 5 Extended
Partition 4 does not end on cylinder boundary.
/dev/sda5 25230 76222 409600000 6 FAT16

dr_agon 08-17-2010 04:27 PM


Originally Posted by lilpirate (Post 4068862)
Is there any way I can get back the Windows Boot Loader menu and have Fedora in it?

Probably there is, but it is easier to have Windows available in GRUB menu.

I assume you have the Windows boot loader in /dev/sda1 (it is the bootable partition), so you just have to tell GRUB to pass control to it.

The corresponding part of my GRUB menu.lst, also booting Windows on /dev/sda1, looks like that:

title Microsoft Windows XP Home Edition at sda1
rootnoverify (hd0,0)
chainloader +1

The error "A disk read error has occurred. Press Ctrl+Alt+Delete to restart" seems to be from Windows loader, but I have no idea what it tries to read.
I can see you have 2 NTFS partitions, so there may be some problem with mapping order, I mean which becomes C: and which D:. Check it, and remap in GRUB config if necessary.
The partition /dev/sda1 looks small - do you have the Windows installed there or on /dev/sda2?

Timothy Miller 08-17-2010 05:30 PM

That sda1 is from Windows 7, it creates a tiny 100 MB partition along with the actual installation partition, acting essentially the same as the linux /boot partition. Windows XP however CANNOT access that, so you're probably going to need to boot from /dev/sda2 instead for XP, or delete the partition and merge the free space into /dev/sda2, making that /dev/sda1.

lilpirate 08-18-2010 07:51 AM

Sorry for replying late, but here's the current status of my problem.

I installed Windows XP. I want remove it now(Yes, because it fails to support my 4 GB RAM )and install Windows 7. As suggested by dr_agon, I had deleted /dev/sda1 and /dev/sda2 and created a single partition to install XP. Now, I'll install Windows 7 on /dev/sda1. Let's see if I face any problem then.

Thanks everyone for replying.


dr_agon 08-19-2010 04:01 AM

It was Timothy's suggestion to merge the sda1 and sda2 partitions ;)

From his post I learnt, that Windows7 probably would recreate small boot partition - is this true? (I don't use W7, but it's good to know)

All times are GMT -5. The time now is 06:28 PM.