LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 10-01-2003, 01:23 AM   #1
maestro52
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora 9
Posts: 177

Rep: Reputation: 30
Question Why won't linux turn my computer off?


This is a totally new experience and has only been happening since I bought my new ASRock K7VM2 motherboard. the last mb I had was an MSI K7T Pro and it worked just fine (until it died), in that my mdk 9.1 would power down and shut off the computer for me when I logged out. Now it powers down, but just sits there forever until I manually shut off the computer. Does anyone know what the problem is or might be?

All help will be greatly appreciated.

 
Old 10-01-2003, 01:37 AM   #2
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
no idea
but my computer is the same (different mobo)

so i'm adding to this in case anyone knows why

then i can sort mine too
(i thought it was supposed to be like that)

doh
 
Old 10-01-2003, 02:01 AM   #3
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
in kde
control center > kde componets > session manager

resett default behavior their

if your in gnome things may be slightly diff'rent
 
Old 10-01-2003, 04:14 AM   #4
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
My computer didn't shut down too. It was like Windows 95, where it stated "It's now safe to turn off the computer".

After compiling my first kernel, with ACPI support (a bios feature for power management), the kernel was able to tell the bios it should power off.

If you want to compile a kernel for the first time, try to get the /usr/src/linux/.config file + other sources your distro has used to compile the kernel. (maybe on the source-cd-rom??) In this way, you'll have a complete configuration that at least, works.. it's easy to forget a few things in your kernel config if you're a newbie
 
Old 10-01-2003, 06:36 AM   #5
poloktim
Member
 
Registered: Feb 2003
Location: Australia
Distribution: Debian
Posts: 104

Rep: Reputation: 15
Compile APM into your kernel.

If you have Debian run modconf (I'm not sure about other distros). It should work.
 
Old 10-01-2003, 09:44 AM   #6
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
Quote:
Originally posted by poloktim
Compile APM into your kernel.

If you have Debian run modconf (I'm not sure about other distros). It should work.
what is modconf.. just curious.

For my kernel compiling, it's "just"
cd /usr/src/linux
make menuconfig
make dep
...bzImage, modules, .. modules_install
and copy the kernel+System.map, configure lilo

 
Old 10-01-2003, 11:06 AM   #7
KB1IKN
LQ Newbie
 
Registered: Oct 2003
Distribution: Debian \ Gentoo
Posts: 11

Rep: Reputation: 0
try in a terminal shutdown -k now (enter) if that doesnt turn it off then try pulling the plug.
 
Old 10-01-2003, 12:17 PM   #8
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
in a terminal type (as root)
shutdown -h now

but

this will almost certainly make no difference

i have mandrake 9.1 on my computer
i set it up
and with this version as with mdk 9 redhat 7.3/8/9 and slackware,
all of which i have installed on this same box
none of them have ever shutdown the box totally
i have had to hit the switch (tho not hold it down for 4 secs)

on my sons pc, which i built
which has an Asrock motherboard in
mdk9.1
which i installed
switched the box off completely

perhaps a BIOS setting ??

i set my sons mobo to the turbo settings and left it that
 
Old 10-01-2003, 12:50 PM   #9
Blinker_Fluid
Member
 
Registered: Jul 2003
Location: Clinging to my guns and religion.
Posts: 683

Rep: Reputation: 63
Ever try the 'poweroff' comand?
 
Old 10-01-2003, 01:34 PM   #10
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
I think all those commands only work if you have good APM or ACPI support
 
Old 10-01-2003, 02:06 PM   #11
KB1IKN
LQ Newbie
 
Registered: Oct 2003
Distribution: Debian \ Gentoo
Posts: 11

Rep: Reputation: 0
Sounds like ./pullouttheplug
 
Old 10-01-2003, 02:09 PM   #12
Megamieuwsel
Member
 
Registered: Sep 2002
Location: Haarlem , the Netherlands
Distribution: VectorLinux SOHO 5.1
Posts: 470

Rep: Reputation: 35
as root:
halt -p

works.
 
Old 10-01-2003, 03:49 PM   #13
maestro52
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora 9
Posts: 177

Original Poster
Rep: Reputation: 30
Question

I don't know what happened here. Perhaps I did not make myself clear enough. I am able to shut off my computer MANUALLY. I am able to use the power button on my computer. I am able to input shut down commands, and the computer does at least go through the appropriate log out and power down procedure.

HOWEVER! The problem is that Linux used to shut off my computer AUTOMATICALLY when it completed the logout/power down procedure and now after installing my new ASROCK K7VM2 mb it will not AUTOMATICALLY shut off the computer.

Running commands to shut off the computer is in no way an automatic process. I checked my KDE Control Center and the Session Manager in Components is and has already been set to shut off the computer after powering down.

I think there is a major possibility of something being wrong in the kernel, although I will check cmos again because of what Salparadise had said,

"on my sons pc, which i built
which has an Asrock motherboard in
mdk9.1
which i installed
switched the box off completely

perhaps a BIOS setting ??

i set my sons mobo to the turbo settings and left it that".

Still there are a few things that have to be considered.

1. I am a and have no idea of what to do with the kernel. If anyone can tell me how and where to check the kernel to see if the powerdown/shut off the computer commands had been corrupted along with offering me the exact information I need to insert into the kernel and exactly where and how to put it in there correctly, while being as gentle with me as possible will be greatly appreciated.

2. Again, I am a , but my ASRock K7VM2 was made SPECIFICALLY for Windows XP and some functions that are programmed into it for Windows most certainly do not work. So I am wondering if that may have somehow screwed the automatic shutoff.

3. My ASRock does not have turbo, or at least I did not notice it. Of course, I am going to check cmos again.

Believe me when I say that I am very thankful for everyones effort to help me, but please remember that I am not haivng any problem using commands or using the computer power button to shut off my computer. It would just be nice as hell if I could get the AUTOMATIC COMPLETE SHUTDOWN back.
 
Old 10-01-2003, 03:57 PM   #14
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
Quote:
n kde
control center > kde componets > session manager

resett default behavior their

if your in gnome things may be slightly diff'rent

I saw the option in KDE
but have no idea where it would be in Gnome

still looking
 
Old 10-02-2003, 01:15 AM   #15
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
the turbo settings were in the save and exit menu in the BIOS
(just in case)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
turn off linux /shutdown computer xprometeus Linux - General 9 09-25-2010 02:18 PM
How do I turn off my computer? DDRfreak2 Mandriva 9 09-12-2005 07:41 PM
turn off computer spidna Slackware 2 08-12-2004 12:18 PM
How to turn off computer ginnytwo Linux - Software 10 07-27-2004 01:13 AM
Getting linux to turn off my computer ChimpFace9000 Linux - General 5 02-03-2003 09:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration