-   Linux - General (
-   -   When I run /sbin/lilo on Debian it says /proc/partitions does not exist (

coldy 03-20-2004 03:00 PM

When I run /sbin/lilo on Debian it says /proc/partitions does not exist
Hello friends, I am using Debian GNU/Linux 3.0r2
I was precompiled my kernel before month maybe, and today I have this error, well before 2 days I preinstalled Windows, than rebooted the system using the first CD of Debian and try to install lilo in MBR.
Can someone help me how to solve this error when I run /sbin/lilo please:

Warning: '/proc/partitions does not exist disk scan bypassed
Added Debian *
Skipping /vmlinuz.old
Added Windows
My kernel is 2.4.24
thanks in advance

GregLee 03-21-2004 09:28 AM

Verify that lilo is right -- from the command line: "ls /proc", "cat /proc/partitions". Perhaps there is no /proc filesystem at all. If not, create one. (1) Check that you requested a proc filesystem in configuring your kernel with "grep PROC /usr/src/linux/.config", which should return "CONFIG_PROC_FS=y". If not, reconfigure your kernel, asking for a proc filesystem, and recompile. (2) Make sure the directory /proc exists, and if not "mkdir /proc". (3) Mount the proc filesystem with "mount proc /proc". Then you should see /proc/partitions. If not, I dunno.

All times are GMT -5. The time now is 04:14 PM.