LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-02-2002, 10:13 AM   #1
purelific
LQ Newbie
 
Registered: Mar 2002
Posts: 24

Rep: Reputation: 15
Unhappy when Booting


Evertime i boot i get to the black screen and prompted to login, and i have to type in startx to get into gnome. and when i do get into gnome i get a error message to add o01-**** to ect/host.
 
Old 04-02-2002, 11:56 AM   #2
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Not enough info, cant' help.
 
Old 04-02-2002, 01:19 PM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 262Reputation: 262Reputation: 262
not sure why it would be asking about or telling you to add something to your /etc/host file.. what do you have in that file ??

-trickykid
 
Old 04-02-2002, 02:32 PM   #4
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 31
please post your /etc/inittab file.

and what distro are you running?
 
Old 04-02-2002, 03:52 PM   #5
bfl
LQ Newbie
 
Registered: Mar 2002
Distribution: Mandrake 8.2
Posts: 10

Rep: Reputation: 0
i get the same message as purelific. whenever i start up gnome i get a message along the lines of "the internet address for my_x_server_name couldn't be found, this will prevent gnome from working properly. try adding the address to /etc/hosts". i'm using mandrake 8.2 right now, but i had the same problem when i was using 8.0. i fixed it with 8.0, but now i forget what i did.
i hope the extra info helps.
 
Old 04-02-2002, 04:36 PM   #6
jatimon
Member
 
Registered: Apr 2002
Posts: 33

Rep: Reputation: 15
do you have an entry for localhost in /etc/hosts?
 
Old 04-02-2002, 09:48 PM   #7
bfl
LQ Newbie
 
Registered: Mar 2002
Distribution: Mandrake 8.2
Posts: 10

Rep: Reputation: 0
alright. so i just installed RH 7.2 (everything was working on MDK 8.2, the fun was gone). when i booted up the first time gnome started right away, but i couldn't connect to the internet. i ran netconf and enabled my ethernet card (pcmcia) and now i can connect, but i'm getting the exact same problem as purelific, it boots me into a command line login, and when it launches gnome i get the "could not find internet address for ..." again. here's what my /etc/hosts looks like
Quote:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
i'm going to start digging to try and solve the problem myself, sometimes it's tough being a gnubie.
 
Old 04-03-2002, 01:21 AM   #8
jackopa
LQ Newbie
 
Registered: Nov 2001
Distribution: Red Hat
Posts: 23

Rep: Reputation: 15
reply to 'WHEN BOOTING' from purelific and bfl

Your question and some of the responses sound a lot like a problem I had last year that was solved with the help of another member, DMR. Try checking your /etc/sysconfig/network file for proper hostname , specifically look at line, HOSTNAME=xxxxx. Somehow system had changed hostname on me and when I changed it back all was well.

Jackopa
 
Old 04-03-2002, 10:33 PM   #9
bfl
LQ Newbie
 
Registered: Mar 2002
Distribution: Mandrake 8.2
Posts: 10

Rep: Reputation: 0
jackopa, thanks for the lead.
purelific, i ran
Code:
su
hostname localhost.localdomain
i think that reset the name of my x-server to localhost.localdomain, which got rid of my gnome warning.

cancel that. it didn't stay when i rebooted.

Last edited by bfl; 04-03-2002 at 10:46 PM.
 
Old 04-04-2002, 10:29 PM   #10
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 31
please post the following files:

/etc/hosts
/etc/sysconfig/network
/etc/nsswitch.conf
/etc/resolv.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting into Single User on MDK 9 asks for root password instead of booting into root acadcworks Linux - General 6 01-10-2006 07:51 AM
booting new kernel. Booting new kernel dies with INIT: VFS issue, really mus335 Linux - General 0 04-21-2004 12:52 PM
Are you dual booting and Windows stopped working (booting) then here's the answer: rberry88 Linux - General 1 02-12-2004 10:05 AM
Booting in X cstehle Linux - Newbie 2 02-21-2002 02:48 PM
booting ,dual booting kmadhukar Linux - Newbie 1 02-02-2002 10:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration