-   Linux - General (
-   -   what is the replacement of the samba "smbmount" command (

jmhalloy 11-17-2007 11:31 AM

what is the replacement of the samba "smbmount" command
I used to use the samba "smbmount" command in order to access a network drive with an imbedded samba server so it looks like a windows server.

In order to mount the samba share to a local empty directory on my linux desktop, the command was:

smbmount //the_server_ip_address/my_userid_on_the_server ./the_local_dir -o username=my_userid_on_the_server,password=my_password_on_the_server,workgroup=WORKGROUP

Unfortunately, after upgrading from suse 10.0 to 10.3, the "smbmount" command does not exist anymore as well as the smbfs which is replaced with cifs

The question is:
What is the replacement of the "smbmount" command and how to use it ?


Jean-Michel Halloy

Brian1 11-17-2007 11:53 AM

Samba was not compiled with smbfs support commands and features. Use the mount command with -t cifs option.


Baloo_PNW 11-17-2007 11:58 AM

Samba has given me nothing but headaches since the switch to cifs.

I'm afraid I can't help you with smbmount, but smb4k is a KDE GUI for mounting samba shares.
After some initial issues (, I've got it working in openSuse 10.3.

jmhalloy 11-18-2007 06:49 AM


I already try the mount -t cifs command with the following syntax before posting for this:

mount -t cifs // ./backup -o userid=my_userid,password=my_password

but I receive the following error

mount error 20 = Not a directory
Refer to the mount.cifs(8) manual page ( mount.cifs)

I read the man page but did not find the possible syntax error

I'm able to see the server directorys from konqueror with smb://

any idee ?

Brian1 11-18-2007 11:07 AM

Is /backup a hidden directory since placing a . infront of it?
If so mount it to just a directory called /backup.


jmhalloy 11-19-2007 02:38 AM

Hi Brian and everybody,

I added the dot to be ./backup to retry after having the same result with /backup



Brian1 11-19-2007 04:06 PM

Got no idea. Used the exact command and directory name and mounted to problem. If nothing in that directory I would delete and recreate.


jmhalloy 11-20-2007 06:03 AM

Hi everybody,

Trying yesterday with smbclient and was able to connect to my remote drive, but this "ftp like" environment does not allow me to perform my easy backup scripts at night.
:-( why did they suppress the smbmount command &@#...!!!
Plan to try putting all the stuff into /etc/fstab with user,noauto... maybe this evening



jmhalloy 12-04-2007 06:18 AM


Still not able to mount the share, even in the fstab since the mount.cifs or mount -t cifs do not work.
I'd like to know how konqueror is able to perform the stuff.
It seems my Packard-Bell NetStore 3500 device does not support CIFS at all.
I plan to try a new firmware on it.


tke1384 02-19-2008 04:11 PM

What works for me
I know this is a little late but I'm looking for a solution to a similar problem but have found a work around for what you are asking about. I would get the same error when I knew there was a folder by that name. I'm working on a Fedora box connecting to an XP machine on a 2003 domain. I found that if I used the command mount -t cifs /remote_machine/shared_folder /local_folder -o it would map just fine or you could use mount.cifs /remote_machine/shared_folder /local_folder -o hope this works for you. Happy Bash.

paklan 02-21-2008 09:36 AM

That looks correct to me.
The package cifs-mount replaces the use of smbmount and (I think) is installed as a default when installing samba and samba client.
Create the mount directory as normal and use
mount -t cifs //machine/service /mountpoint -o "user=winuser,password=hfhf,domain=workgroup"

Notice the double slash on the front of the machine name.

You should now also be able to set this up in fstab and allow non root users to mount and unmount the service.

See the man page for mount(8) and mount.cifs(8).
"man mount"
"man mount.cifs"


jmhalloy 06-03-2008 11:59 AM


The mount -t cifs did not work even after installing a new firmware.
Since I do not receive any answer from the NAS vendor, I'll never by any packard bell anything

JohnnySnowman 12-17-2008 01:05 PM

this worked for me
Sorry for the late post... just joined this forum.

in the man entry for mount.cifs, note the information about setting security mode.

adding sec=ntlmv2 worked fine for me connecting to w2k3 service pack 2 box.

Hope this helps somebody out.


All times are GMT -5. The time now is 08:05 AM.