-   Linux - General (
-   -   warning in log file, what does it mean? (

gabadoo 03-20-2002 06:23 PM

warning in log file, what does it mean?
Hello, I have the following warning in my /var/logs/messages file:

Mar 20 19:00:37 www xinetd[1302] warning: cannot get client address: Transport endpoint is not connected.

Anyone have a clue as to what this means and how i can go about fixing this. I run redhat 7.2 and Im a newb so any help would be appreciated



taz.devil 03-20-2002 06:31 PM

xinetd is a newer version of inetd which is an Internet Server Daemon. You may want to read up as far as whether or not you want it running at all. If not, you can just take it out of the init list. If you do want it for some purpose, it'll just need some configuration as far as server client relationships etc...

Sixpax 03-21-2002 11:33 AM

xinetd is a program that looks for incoming connections to your machine and starts up the appropriate service (FTP, telnet, web server, etc). In the case of this error message, the www service is complaining. If you aren't running a web server, just go into the /etc/xinetd.d directory and either delete the webserver file (www maybe?) or edit it and set "disable = yes".

gabadoo 03-21-2002 12:44 PM

Well thats the problem, I am trying to setup this machine as a web server. So are you saying that the theres something wrong with the web service. I just formated the box because my server died like 2 weeks ago unexpectedly, and it would not reboot. Heres the info i posted before concerning that:
Hello, my webserver died the other nite and now it wont reboot. I used the redhat 7.2 rescue option to mount sysimage. I was able to get a prompt and reviewed the logs and heres what i encountered.

Mar 11 17:46:07 webe kernel: hostname uses obsolete (pf_inet,sock_packet)
Mar 11 17:46:07 webe kernel: device entered promiscuous mode
Mar 11 17:46:07 modprobe: Cant locate module ppp0
Mar 11 17:50:30 webe kdm[28148]: Server unexpectedly died
Mar 11 17:55:22 webe ftpd[28272]: FTP session closed
Mar 11 17:55:22 webe telnetd[28273]: ttloop: peer died: EOF
Mar 11 17:55:23 webe xinetd[28276]: warning cant get client adddress: transport endpoint is not connected

Mar 11 22:11:00 webe modprobe: modprobe: cant locate module binfmt-464c
Mar 11 22:11:01 webe last message repeated 5 times
Mar 11 22:11:01 webe syslogd 1.4.1:restart
Mar 11 22:11:01 webe modprobe: modprobe: cant locate module binfmt-464c
Mar 11 22:28:06 webe last message repeated 20 times

repeats until this:

mar 12 02:43:18 webe kernel: VFS: file-max limit 8192 reached
mar 12 04:02:00 webe syslogd 1.4.1:restart


As you can see the same error is in both the logs from the box that died, and now its in the newly formatted box. So now i reformated and have done a straight rehat 7.2 install and selected to add apache. So im kinda confused why im getting this error. I really have no clue what its saying and im kinda frustrated at this point, cause im just waiting for the same problem to happen again :(

Sixpax 03-21-2002 05:07 PM

All of the web servers that I've seen run their httpd processes without inetd/xinetd. I have a feeling you don't even need the one in /etc/xinetd.d. You may want to examine it and see exactly what it's for.

taz.devil 03-21-2002 05:37 PM

That's probably the best idear. Get rid of xinetd and just configure and run Apache (httpd) for your web serving needs. (x)inetd is supposed to help reduce the load on your system as the man pages say by only running one daemon until another is needed, say web server, then listens and if it sees an FTP request will startup your FTP daemon, etc... Quite a hassle in my opinion...If you are gonna just run apache, then that's all you need anyhow.

Sixpax 03-21-2002 07:35 PM

Well I wouldn't necessarily advise killing xinetd altogether. It is pretty good at what it does (can you even telnet to a box that isn't running it?), but it's just not suited for running web server daemons from IMO.

All times are GMT -5. The time now is 11:58 AM.