LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-27-2003, 02:39 PM   #1
SForsgren
Member
 
Registered: Apr 2003
Location: San Jose
Distribution: Red Hat 9
Posts: 68

Rep: Reputation: 15
vsftpd - Why is it trying to start at boot?


When I start my Linux box, after xinetd and ntp start, I see

starting vsftpd for vsftpd

Why? I do not have a vsftpd file in /etc/xinetd.d

What else would be causing it to show starting vsftpd at boot?

If I go do ps -ef | grep vsftpd

after login, it is running. I just don't understand why.

Also, I still have listen=YES in vsftpd.conf, so I didn't think that xinetd would be able to start it unless I had that set to NO?

My goal was to get it running at startup, but now I am not clear as to how it is starting.

Thanks
 
Old 04-28-2003, 12:54 AM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
vsftpd is almost certainly setup as a service to start at boot. Select "services" from your menu and you can unset unwanted services so they do not start at boot.
 
Old 04-28-2003, 10:44 PM   #3
SForsgren
Member
 
Registered: Apr 2003
Location: San Jose
Distribution: Red Hat 9
Posts: 68

Original Poster
Rep: Reputation: 15
You are correct. I figured this out yesterday after more poking around. Thanks bulliver. I guess what I don't understand yet though is are there several places that it looks to start things? So, all the services, all the items in xinetd.d, etc.? Since there were some options I could set in xinetd.d if I created a vsftpd file there, how are those "like" options set when it is run by the Services?

When running via xinetd.d, I could set the options below.

# vsftpd is the secure FTP server.
service ftp
{
disable = no
socket_type = stream
wait = no
user = root
server = /usr/local/sbin/vsftpd
per_source = 5
instances = 200
no_access = 192.168.1.3
banner_fail = /etc/vsftpd.busy_banner
log_on_success += PID HOST DURATION
log_on_failure += HOST
}

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto setup VSFTPD start up at boot longnam Slackware 1 08-13-2005 12:14 PM
how to start and configure VSFTPD QiEr Linux - Newbie 2 02-02-2005 09:10 PM
Start vsftpd with inetd Thinkgeekness Linux - Software 25 07-02-2004 08:01 AM
Can't start vsftpd -- OOPS: socket Rosco8255 Linux - Software 7 10-22-2003 01:51 PM
inetd doesnt start vsftpd suse rvn Linux - Newbie 11 10-15-2003 03:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration