-   Linux - General (
-   -   Volume group "VolGroup00" not found (

tornado_11 04-07-2007 12:29 PM

Volume group "VolGroup00" not found
Hello colleagues!

My current kernel is and it works fine!

I'm trying to compile and install the new kernel. My steps:

1.I created /usr/src/linux- folder and extracted kernel source here
2. make clean
3. make mrproper
4. make gconfig with setting my CPU type (AMD)
4. make bzImage
5. make modules
6. make modules_install
7. make install

But! When I'm trying to boot with the new kernel I get the error:

Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol00 ...

this is my grub.conf

title Fedora Core (2.6.18-1.2798.fc6)
root (hd0,2)
kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-1.2798.fc6.img
title test
root (hd0,2)
kernel /vmlinuz- ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-

I have no idea what is this :(

btmiller 04-07-2007 12:46 PM

Did you compile logical volume support into the kernel or make sure that a module capable of supporting LVM is on the initrd? It sounds like your kernel can't read logical volumes.

tornado_11 04-07-2007 01:10 PM

Could you please say me what it is the parameter name in the config file to support LVM?

tornado_11 04-07-2007 01:20 PM

Under Multi-device support RAID and LVM I have the following
Options Name Value

Multiple devices driver support (RAID and LVM) (NEW) MD Y
Device mapper support (NEW) BLK_DEV_MD M

Should the "Device mapper support" be as Y (in kernel)?

Thank you!!

tornado_11 04-07-2007 02:11 PM

Ok, I added "Device mapper support" into kernel. But I get the same error :(

Quakeboy02 04-07-2007 02:55 PM

Did you add it by editing .config or using make menuconfig? And just to be clear, you rebuilt (starting with make clean) and reinstalled the kernel after changing the config?

tornado_11 04-07-2007 03:03 PM

yes, my steps:
1. make clean
2. make mrproper
3. here I change my .config using make gconfig
4. make bzImage and etc

by the way how can I verify that some parameters are set correctky after the kernel compilation? For example now I'm running the 2.6.18 kernel and I want to see if BLK_DEV_MD is set. Is it possible?

P.S. Now I'm trying to compare the config file of my current kernel (under /boot) to config file that I created.

tornado_11 04-07-2007 03:07 PM

by the way output of df -hT
Filesystem Type Size Used Avail Use% Mounted on
ext3 115G 6.5G 102G 6% /
/dev/sda3 ext3 99M 17M 78M 18% /boot
tmpfs tmpfs 1004M 0 1004M 0% /dev/shm

I see that my current FS is ext3 but in the config file the ext2 is built-in into kernel and ext3 is as module EXT3_FS (M). Is it relevant?


Quakeboy02 04-07-2007 03:13 PM

copy your current config to .config and modify that if necessary, rather than trying to create a proper .config from scratch. Since your working config *works* just run make oldconfig after you copy it over to .config and make sure there aren't any new modules that you need to enable/disable, and then build your kernel from that.

I believe that make mrproper deletes the .config file. It's not normally necessary to do that unless things are really borked badly. make clean is usually enough.

tornado_11 04-08-2007 02:17 AM

Ok I did what you said. But I get the same error. Somehow the kernel cannot work with logical partition. When I was installing my distribution I used automatic partition and my root file system is mounted on the logical volume. I ran "make install" it should create ramdisk to handle the LVM issue.

tornado_11 04-08-2007 05:52 AM

It sounds like the ramdisk with root file system does not load. How can I check this?

Quakeboy02 04-08-2007 01:25 PM

Did you check the grub entries to make sure they are the same as for the old working kernel? Did you see update-initramfs run? Please verify that you copied the working config to .config and that you DID NOT make any manual changes to the file, and made ALL of your changes using make gconfig.

tornado_11 04-08-2007 03:28 PM

yes I copied the working .config and did changes only using gconfig. In addition I found this nice article
about ramdisk. It still does not work. Then I decided to leave the LVM and use the custom partitioning. I have two hard disk. On the first I have the Win and on the second I wanted to install FC6. So I started the installation, selected the custom partitioning and did it without LVM. After the restart .. nothing. I have only Windows. Where is the grub? :( Is it possible to install Win and Linux on different hard disks?

Quakeboy02 04-08-2007 03:33 PM

You will need to have grub on the disk that the BIOS boots.

tornado_11 04-08-2007 03:40 PM

How can I ensure this? I didn't select where to install grub, by default it is installed on the correct disk (where the Win resides)

All times are GMT -5. The time now is 09:46 AM.