LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 06-17-2001, 12:01 PM   #1
mechanek
LQ Newbie
 
Registered: Jun 2001
Location: Olathe, KS
Distribution: RedHat 8.0
Posts: 10

Rep: Reputation: 0
Angry


Hello I have a question about VNC connections.
I have a homeLAN with two computers; 1)runs win98 2)redhat 7.0 using kernel 2.2.19-7.0.1.
Both have VNC 3.3.3r2
My question is is there a windows manager that can be installed on my win98 box that will properly handle G.N.O.M.E.?
When I connect to my linux box a warning pops up that says:
Warning you are not running a GNOME compliant window manager GNOME support by window manager strongly recommended
The vncserver file is set to 800x600 res and 16bit color and even though I can manage as is..boy does the screen really look WONKY

Any help is appreciated thanks,
mecnanek
 
Old 06-19-2001, 12:18 AM   #2
mechanek
LQ Newbie
 
Registered: Jun 2001
Location: Olathe, KS
Distribution: RedHat 8.0
Posts: 10

Original Poster
Rep: Reputation: 0
bump
 
Old 06-19-2001, 09:11 PM   #3
mechanek
LQ Newbie
 
Registered: Jun 2001
Location: Olathe, KS
Distribution: RedHat 8.0
Posts: 10

Original Poster
Rep: Reputation: 0
Angry

So does no one know, or do you just don't care, or is this the wrong forum for this to be posted in???
 
Old 06-20-2001, 03:18 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
Red face

Unless i'm very much mistaken.... It's totally irrlevant which window manager you are using, as vnc just sends screenshots down teh network to you... all you see in the vnc window is a picture that the linux box drew itself...
So, you're question really doesn't make sense... Read the vnc guide more.. there's probably more options aviablable to you.

chris
xxxx
 
Old 06-20-2001, 05:04 PM   #5
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 47
Quote:
Originally posted by mechanek
So does no one know, or do you just don't care, or is this the wrong forum for this to be posted in???
A lack of responses does generally indicated that people don't know the answer... If it was posed in the wrong forum then it would either be moved by a moderator or someone would have mentioned it.

As for not caring, people wouldn't read the messages and be members of the site if they didn't want to help.

Unfortunately I have never used VNC so can't help.

Jamie...
 
Old 06-23-2001, 01:29 PM   #6
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
VNC

Mine starts with twm running a console, I don't know what you are looking at here but I will assume it's the same.

I go back to my ssh console and do the following

ps -a

look for PID for twm

kill PID

or maybe just

killall twm

then

gnome-session

if you are not logged on in another console, I don't guess it matters. just try it.



thats it, gnome starts with sawfish, my wm for that user.

Last edited by DavidPhillips; 06-23-2001 at 01:50 PM.
 
Old 07-03-2001, 11:27 PM   #7
mechanek
LQ Newbie
 
Registered: Jun 2001
Location: Olathe, KS
Distribution: RedHat 8.0
Posts: 10

Original Poster
Rep: Reputation: 0
To clarify my request.
I am connecting to my linux server from a Windows computer.
I can connect no problem.
My problem is that when I connect a warning about not having a GNOME compliant window manager comes up and tells me that my display may look improper.
And it does; it looks like I'm looking at a negative of a photograph.

So is there a windows manager out there that can be used in windows to display a GNOME desktop properly?
 
Old 07-03-2001, 11:53 PM   #8
mechanek
LQ Newbie
 
Registered: Jun 2001
Location: Olathe, KS
Distribution: RedHat 8.0
Posts: 10

Original Poster
Rep: Reputation: 0
Ok tried killing "twm" recieved same error about not using a GNOME compliant window manager.
Tried killing both "twm and gnome-session" same result.

Now I can goto my server phsyically and use it with no problems running GNOME just enter startx and poof its up and running clear as a bell.(It looks better graphically than my windows machine). It's just a hassle to have to go to another location when I need to do some minor adjusting to the server.
Thats why I love using the VNC program. I just want the graphics to look normal wilst using it.
 
Old 07-06-2001, 12:49 AM   #9
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
vnc

Try starting a window manager before starting the gnome-session.
 
Old 07-06-2001, 04:25 PM   #10
doodah
Member
 
Registered: Apr 2001
Location: Columbus,OH
Distribution: slackware
Posts: 122

Rep: Reputation: 15
check your

~/.vnc/xstartup

file to make sure a desktop is being called properly.. make sure it has a hider (' & ') to the right of it.. the message about a gnome compliant window manager is not coming from windows, it has to be coming from X.. if that does not work try to connect from a browser, and see what happens... oh yeh, the colors can be fixed by matching the depth options on vnc to the ones on you desktop with the -depth option..
 
Old 08-23-2001, 10:49 PM   #11
glenw
LQ Newbie
 
Registered: Aug 2001
Posts: 1

Rep: Reputation: 0
Don't know if u've solved your problems yet, but all i did was edit the xstartup file, commented out all lines, then added one single line: gnome-session (if that's what u want). Don't know why default is twm, it's so nasty. Didn't kill/restart vncserver to make the change.
Good luck.
 
Old 08-24-2001, 03:47 PM   #12
doodah
Member
 
Registered: Apr 2001
Location: Columbus,OH
Distribution: slackware
Posts: 122

Rep: Reputation: 15
yes very nasty, but bandwith friendly
 
Old 11-06-2001, 07:26 PM   #13
ddstyles
LQ Newbie
 
Registered: Nov 2001
Location: Auckland NZ
Distribution: Linux Mint
Posts: 18

Rep: Reputation: 0
thanks glenw - the gnome-sessions thing worked a treat.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for some help via VNC Wolvenmoon Debian 4 08-18-2005 02:12 PM
Vnc carlosinfl Fedora 6 02-03-2005 06:47 AM
need VNC to allow 'logout/login' from Gnome (gnome & VNC runs fine) spudler Linux - Networking 3 11-14-2004 10:02 AM
about vnc dummyagain Linux - Networking 1 09-24-2004 01:17 AM
VNC - Selecting different WindowManagers with VNC cmfarley19 Linux - Software 0 04-16-2003 02:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration