LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 09-17-2001, 05:03 PM   #1
Aurga
LQ Newbie
 
Registered: Sep 2001
Distribution: Debian - Potato
Posts: 21

Rep: Reputation: 15
Question VNC and Gnome


Im having a problem using gnome through vnc. The server connects, but no desktop appears. I have added gnome-session & in my xstartup file, but to no avail. In fact ever since ive reinstalled debian, ive had this problem. Am i missing something?
Any suggestions?
 
Old 09-18-2001, 01:15 PM   #2
Aurga
LQ Newbie
 
Registered: Sep 2001
Distribution: Debian - Potato
Posts: 21

Original Poster
Rep: Reputation: 15
It has become clear that everyone is as baffled about this problem as i am. I have asked the same question in all kinds of places, including on irc.debian.org in #debian. No ideas from anyone. Im hoping with more of a background may help.

A little more background. I am running debian- potato.
My xwindows works fine, in kde, twm, and window manager (gnome). Prior to this, i was running debian - potato, with xwindows NOT working, however my gnome sessions through vnc worked fine. I have since had to reinstall debian. At first Xwindows in the new installation was not functional. Neither was my VNC sessions. Assuming this was a problem with xwindows, i finally got it X to work, but still no luck with VNC.

Problem: I am trying tio run gnome, or kde, or anything through a vnc session. My vnc server works, and no errors that are pertinant are reflected in the log files. I can connect to the server, yet no desktop appears, even though I have "gnome-session &" in my xstartup file.

I have also tried putting "startkde &" and "twm &" in my xstartup file. None of those creates a desktop. I have tried changing the xstartup files permissions, it is currently totally accessable by anyone, as a last stitch effort to try to resolve this.

Is there anything else i should be aware of? I know the vnc server works by accessing /etc/X11/Xsession file for guidence but, im assuming that if my xwindows works fine, that this file is not the problem.

Any suggestions at all? In the slightest?
 
Old 09-18-2001, 01:20 PM   #3
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Sorry if this is a stupid comment, I've never used VNC as a server on linux but... Doesn't the VNC server need to start X, not just the Window manager? So you would get it to call startx or xinit, not gnome-session. Yeah??

cheers

Jamie...
 
Old 09-18-2001, 01:26 PM   #4
Aurga
LQ Newbie
 
Registered: Sep 2001
Distribution: Debian - Potato
Posts: 21

Original Poster
Rep: Reputation: 15
Its not a stupid comment, nothing is stupid when trying to trouble shoot!

Im my experience with vnc through linux, it usually just calles the window manager, and dosent actually start the server. However, it couldnt hurt to try it, and I will, and thus I edit this post with the outcome of it.

Thanks for replying jharris.

Outcome:

Sadly nothing happened Jamie, so im back to square 1.
Grrrrrrrrr!
:smash:

Last edited by Aurga; 09-18-2001 at 01:33 PM.
 
Old 09-18-2001, 02:08 PM   #5
matt
Member
 
Registered: Jul 2001
Location: Chicago
Distribution: RH7.1 ; OSX
Posts: 62

Rep: Reputation: 15
Hmmm... I've only done this once, and I don't have the right stuff on me right now to really be sure of this, but I think this is how I got mine working:

From a terminal window, logged in as root, I typed:

#vncserver

When it gives you the session prompt, you have to assign a window to it. So instead of typing in 'mylinuxbox' you need 'mylinuxbox:1' Then when you log in remotely, you'll need the ':1' after the name/IP. Then give the password. Also make sure the VNC server is started, which may be as simple as #vncserver start - but I can't recall for sure. There's documentation all over the VNC site which has the correct commands if these don't work.

Hope this helps - sorry I can't be more specific right now. Maybe it'll at least nudge you in the right direction.

Cheers!
)M.
 
Old 09-18-2001, 03:05 PM   #6
Aurga
LQ Newbie
 
Registered: Sep 2001
Distribution: Debian - Potato
Posts: 21

Original Poster
Rep: Reputation: 15
Matt,

yes, you must type vncserver (just vncserver starts vnc..), but you shoud not run vncserver as root, because that opens up a whole can of worms, as you can imagine.
Vncserver can be run as a regular user, and you will be shown each destop accoringly, because yes, each desktop is numbered to avoid confusing between several users running a vncsession.

I log in properly, with the following syntax:
mylinuxIP:1 or mylinuxIP:2
depedning on the session number.

I have also tried logging in through the web with http://mylinuxIP:5801 or http://mylinuxIP:5802
depening on the session number, with teh same result.

I can log into the session fine. The server accepts my connection, i just dont get a desktop to display. Its just a blank screen with an "X" for a pointer, and no amount of mouse clicking will bring up a window/menu. In essence, VNCserver is behaving as if no window manager, or program (ex. kde or twm) has been called in the xstartup file. I have tried every version of window manager in the xstartup file, so it cant just be a gnome related problem.

I checked the VNC site and have followed the directions for VNC, unfortunetly, it only gives instruction for the vncserver/viewer itself and not about tweeking any problems on linux, however I will root through it some more later, as i have not had luck as of late with finding the info i need on that site or on google, or anywhere else for that matter. Everythign seems to be.. (notice i said SEEMS) to be set up fine... there has to be something i am missing, i just cant for the life of me figure out what that is...

*sigh*
 
Old 09-19-2001, 04:01 PM   #7
matt
Member
 
Registered: Jul 2001
Location: Chicago
Distribution: RH7.1 ; OSX
Posts: 62

Rep: Reputation: 15
Wow, I'm outta ideas. All I can think of is a reinstall.

When you do figure it out (and you will!), please post the answer.

)Matt.
 
Old 09-19-2001, 08:34 PM   #8
Breezwell
Member
 
Registered: Apr 2001
Location: Chicago
Distribution: Gentoo 1.4
Posts: 214

Rep: Reputation: 30
I have VNC running on a Mandrake 7.2 system. Here is what I did to get it going:

1. Log in to your Linux box as root.
2. Copy the VNC .tar file into /usr/local/src
3. tar -xvzf <VNCfilename>
4. cd into the directory your unzipping creates.
5. copy the following files into /usr/bin
1. vncconnect
2. vncpasswd
3. vncserver
4. vncviewer
5. Xvnc

6. Make sure you can ping this system from another system.

7. type the following on the Linux system that you just installed
VNC on ./vncserver

8. This will inform you as to the session number of the VNC server.
This will typcially be localhost.localdomain:1
You may also be prompted to supply a default password.

9. If your other macine is a Linux box (with VNC installed in the same manner) type the following from the /usr/bin directory:

./vncviewer

10. Type in the IP address of the VNC server as such:

yourIPaddress:1

11. Provide the correct password.

12. Hit enter and you should get the default GUI of your VNC server according the version you have.

13. You can have Gnome be the default VNC GUI by going into:

/root/.vnc/xstartup

and change the last line to the following:

gnome-session &

The version of VNC I used is as follows:

vnc-3.3.3r2_x86_linux_2.0.tgz


Hope this helps.
 
Old 09-19-2001, 11:17 PM   #9
Aurga
LQ Newbie
 
Registered: Sep 2001
Distribution: Debian - Potato
Posts: 21

Original Poster
Rep: Reputation: 15
Breezwell,

I used apt to install vncserver. It works fine before. I even uninstalled and reinstalled. Im using vncserver version 3.3.3.

Everything works, it just dosent bring up any desktop no matter what I do! Perhaps, if you can paste me your xstartup file, I will compare what you have with what i have, because its definetly not working.

The vncserver runs fine, no errors in the log files, just no desktop is displayed. no desktop is displayed no matter what window manager i use. twn kde or otherwise. Thats the only problem. I have a suspicion that its a problem perhaps with the xstartup file? I believe this, because the vncserver is acting as if there is no desktop being called. It opens, however I just get a grey screen, and thats it! Ive read the FAQ and documentation, but to no avail. Nothing was in there was helpful, as my setup is how they have it documented.

Paste me your xtartup file. Lets get this ball on the roll. Noone can seem to find out what the hell the problem is. Ive tried to run it as root and a normal user. No luck either way. I wish the log file showed some error!! AT least then id have something to go on.

Im Terribly frustrated...

:smash:
 
Old 09-20-2001, 10:22 AM   #10
Breezwell
Member
 
Registered: Apr 2001
Location: Chicago
Distribution: Gentoo 1.4
Posts: 214

Rep: Reputation: 30
I will post my xstartup file as soon as I get home tonight for ya.
 
Old 09-20-2001, 01:56 PM   #11
Fusion
LQ Newbie
 
Registered: Sep 2001
Posts: 5

Rep: Reputation: 0
I, too, would be interested if anyone finds "the" solution. I am running RH 7.1 and am experiencing the same problems: Login goes fine, but no desktop ever appears!
 
Old 09-20-2001, 08:07 PM   #12
Breezwell
Member
 
Registered: Apr 2001
Location: Chicago
Distribution: Gentoo 1.4
Posts: 214

Rep: Reputation: 30
Ok, here is my xstartup file:

#/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &

gnome-session &


If this does not work for you, you may want to try downloading VNC from the following site:

www.uk.research.att.com

Install according to my previous post and it should work as long as you have Gnome installed on your system. Again, I did my install on Mandrake 7.2.
 
Old 09-20-2001, 08:18 PM   #13
Aurga
LQ Newbie
 
Registered: Sep 2001
Distribution: Debian - Potato
Posts: 21

Original Poster
Rep: Reputation: 15
Breezwell,

It didnt work...

Will try installing it without apt this time... will let you know what happens. I'll have to do this tomorrow through. Thanks for your help.
 
Old 09-25-2001, 11:22 AM   #14
Fusion
LQ Newbie
 
Registered: Sep 2001
Posts: 5

Rep: Reputation: 0
Thanks for everyone's help. I've tried the xstartup suggestions also with no luck. I've done some testing to see where the breakdown MAY be occurring, and I've found:

(Note that, at this point, I'm only working with two machines: a Linux box and a Win2k box.)

1) The Linux vncviewer will successfully connect to the Linux vncserver (same machine) -- so it appears that the Linux box can communicate with itself.

2) If I install the Win2k vncserver on my Win2k machine and try to access it from the Linux vncviewer on the Linux box, the connection ALSO works successfully. In other words, I can connect to my Win2k server from the Linux client flawlessly.

So...the ONLY connection that is NOT working is the one I actually want -- Win2k client to Linux vncserver. Incidentally, I've also had better luck on the connections that HAVE worked using the gnome-session parameter in the xstartup rather than using kde or twm.

That's what I know. Thanks again for everyone's help.
 
Old 02-08-2002, 10:50 AM   #15
ALittleSlow
LQ Newbie
 
Registered: Feb 2002
Location: Bloomington, IN USA
Distribution: RedHat 6.x-7.x
Posts: 2

Rep: Reputation: 0
Lightbulb

I'm coming late to this thread, hope it's in time.

I have three ideas.
Here is an excerpt from www.uk.research.att.com:
Q16 I connected to my Unix VNC server and I just see a grey desktop with a cursor.
After the vncserver script has started the Xvnc server, it then runs your ~/.vnc/xstartup script. By default this will try to start the twm window manager, but if twm isn't on your path, or if you prefer something else, you can edit xstartup. The log file may also give you clues about what is happening.

In Blackwell's xstartup, the first line should be
#!/bin/sh
not
#/bin/sh

Finally, it looks to me like something is hanging between the launch of Xvnc and the execution of your window manager (duh! I guess you knew that much!). Make sure your xstartup is readable and executable by you. Intersperse some echo commands in your xstartup to see if you can isolate where the hangup is, as in:
#!/bin/sh
echo "xstartup started" >/tmp/vnc.log
xrdb $HOME/.Xresources
echo "xrdb finished" >>/tmp/vnc.log
xsetroot -solid grey
echo "xsetroot finished" >>/tmp/vnc.log
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
echo "xterm started" >>/tmp/vnc.log
twm &
echo "twn started" >>/tmp/vnc.log

Good luck!
-Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need VNC to allow 'logout/login' from Gnome (gnome & VNC runs fine) spudler Linux - Networking 3 11-14-2004 10:02 AM
Gnome and VNC acting up RiR Linux - Software 5 02-27-2004 06:49 PM
Gnome and VNC laurentbon Slackware 3 10-08-2003 09:30 AM
gnome and vnc android1654 Linux - Software 2 07-03-2003 02:04 AM
GNOME in VNC? gauge73 Linux - Networking 20 06-21-2003 05:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration