LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Vmware Salck 9.0 as Guest ? (https://www.linuxquestions.org/questions/linux-general-1/vmware-salck-9-0-as-guest-63222/)

Gerardoj 06-02-2003 01:32 PM

Vmware Slack 9.0 as Guest ?
 
Hi I would like to know if I can Install Slackwre 9.0 as Guest?, Now I have Redhat 8.0 as Host but when I type setup appear me that " No linux partitions Detected" and "No swap space detected" how can I install? and what I need to do ?

Thanks

StonedZealot 06-07-2003 04:46 PM

Sorta answer...
 
Well, you need to format the virtual disk as Linux. After you get to the terminal in the slack 9 install (where you typed "setup") you have to use cfdisk (or fdisk if you're adventurous) to format the drive as Linux. It's really easy to use, just create a partition and set the type to 82. If you want a swap partition, make two and set the type of one (the larger one) to 82 and the other to 83. These numbers are all listed when you choose type so don't worry about that...

The problem that I had however, was that in cfdisk, it didn't recognize the virtual disk as 4GB, it recognized it as 670 and some odd MB. I've been trying to get around this with no success...

Gerardoj 06-07-2003 08:27 PM

Hi, you have reason it didn't recognize the virtual disk as 4GB, it recognized it as 670 and also I tried to configutre my partition but, gave me errors like:

Partition the hard disk fdisk <CR> =enter key
p<CR> (to prints my current partition table DOS partition will shown)
n<CR> (to create my new partition)
p<CR> (primary partition type)
2<CR> (partition number 2)
xxx<CR> (where xxx is the first available cylinder number offered)
+xxxM<CR> (where xxx equals two times the system memory)
n<CR> (create new partition)
p<CR> (primary partition type)
3<CR> (partition number 3) = ERROR =partition is alredy defined delete before re-adding and if
I try with other number to primary partition appear me No free sectors available then I jump to

w<CR> (write the partition table and exit fdisk) ERROR unable to write /dev/hda

I tried with cfdisk but appear me in the beginning "opened disk read only you have nop permissions to write then apear me
no partitions table or unknow signature on partition table, do you wish to start with zero table (y) (n) ? Y

then
Disk Drive /dev/hda
Par Type---------FS Type----------Size MB---
Pry/Log Free Space 690.93MB

What can I do? please help me!!

Thanks a lot

Coldfirex 06-21-2003 11:41 AM

same thing here too

apsn 06-22-2003 07:41 PM

Try using a kernel that contains SCSI drivers. The virtual disk is configured as scsi so you won't be able to install to it without the right kernel.

Coldfirex 06-23-2003 11:41 AM

Thanks. I loaded scsi.s instead of the bare kernel and it loaded just fine. I then got an infinite loop problem after setting up my partitions, but I figured out I had to install LILO to the MBR.
Thanks!

Gerardoj 06-23-2003 12:25 PM

Hi Coldfirex,

how did you loaded scsi.s instead of the bare kernel ? or what else did you do?, do you fixed?, what kernel did you used? Thanks

apsn 06-29-2003 08:55 PM

Set your bios to boot your cdrom, put in the slack cd and start your virtual machine. At the boot prompt, boot scsi.s instead of bare.i.

By the way, if anybody is using a windows guest installed on a raw disk partition with vmware 4.0., can you tell me if there's any way to mark the linux bootable partition read only to the vm.
All instructions I've seen indicate that the install wizard should provide a screen with the ro, rw and none options, but for some reason I'm not getting it with the slackware install. I have exactly the same installation on a SUSE box and I get the screen. Don't know why not in slack......
I'm hoping there's some other way to set the attribute... edit a file maybe?


All times are GMT -5. The time now is 05:56 AM.