LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-08-2002, 09:56 PM   #1
marktaff
Member
 
Registered: Jun 2001
Location: Bellevue, WA (Seattle)
Distribution: SuSE 9.3-10.0
Posts: 53

Rep: Reputation: 15
VMware 3.0 insane keyboard repeat rate


All,

I have encountered a most infuriating problem installing RH 7.1 (or 7.2, why not try all options? Both on CDROM) as a guest operating system in VMware workstation 3.0 on a win2k host.

The keyboard repeat rate at the install prompt and install procedure (text mode) is insane. For every _very_ quick keystroke, 12-18 keystrokes are sent to the virtual machine (like: `ttttttttttteeeeeeeeeeexxxxxxxxxttttttttttt`).

It is simply impossible to install this way. I have a MS Natural Keyboard Pro (also tried plain-jane compaq keyboard). I have tried adjusting the keyboard settings in the control panel as well.

I have also uninstalled and reinstalled VMware. I've read every manual, troubleshooting, documentation page, and forum I can find, and still can't find any reference to anyone who's had a similiar problem.

My system:

win2k sp2 & RH 7.2 dual boot (trying to install a fresh copy of RH into virtual machine, not use existing copy).
AMD K62 400MHz
256 MB Ram

Thanks.

Mark
 
Old 02-23-2002, 07:39 PM   #2
quegi66
LQ Newbie
 
Registered: Feb 2002
Posts: 2

Rep: Reputation: 0
hotkeys is an app in sourceforge that has a fix for just that problem.



from the hotkeys man:

-F, --fix-vmware=TIME This option is mainly for users who run both hotkeys and VMware at the same time. Since VMware will delete some of the information from the memory of the X keyboard configuration due to reasons that I don't understand, a thread will be created to restore the neces*sary information regularly. The default time interval is 10 seconds. You can specify a time interval as you like, the value is in seconds. I don't think this option will have any side-effect to the operation of VMware, but if you find that this is not true, please file a bug report. (This option is just a hack, I will implement a nicer method to replace it.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard repeat rate joshknape Mandriva 1 11-03-2005 07:46 PM
Keyboard repeat speed issues Shotgun84 Mandriva 1 08-03-2005 07:29 PM
mouse scrool and keyboard delay/repeat monohouse Linux - Software 3 11-02-2004 07:34 AM
How do you set the keyboard wait-until-repeat delay? deanbrown3d Linux - Newbie 2 06-18-2004 09:35 AM
Easy question: how do I adjust the keyboard repeat rate? aweir14150 Mandriva 1 05-29-2004 12:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration