-   Linux - General (
-   -   vgcreate fails Incorrect Metadata area header checksum (

newbuyer17 03-30-2013 12:51 PM

vgcreate fails Incorrect Metadata area header checksum
I have a HP n40l micro server, running debian, with openmediavault installed as packages.
I have been running fine for a while with the 250Gb internal drive and another 2Tb drive.
LVM is also running fine.

I tried adding an old 250Gb sata drive and couldn't get it to create LVM volumes. Decided it was a duff or incompatible drive, and am now trying to get a Samsung 1Tb drive working, but getting the same errors.

I have tried manually, and through system-config-lvm, and through openmedia vault but the error message is always the same.

Disk show up OK in bios, and I can format it as ext3 without issue.

vgcreate command failed
/sbin/vgcreate -M2 -l 256 -p 256 -s 4m -c n vgtest /dev/sdc1
Incorrect medtadata area header checksum

Trying manually:

fdisk /dev/sdc

WARNING: DOS-compatible mode is deprecated. It's strongly recommended to
switch off the mode (command 'c') and change display units to
sectors (command 'u').

Command (m for help): dsisk -l /dev/sdc
No partition is defined yet!

pvcreate /dev/sdc

Doesn't list the physical volume, only my previous one.

Which is strange, as earlier I did at least have 2 physical volumes.

I have messed around in BIOS with Sata settings and that hasn't made any difference?
Done a debian update and that didn't make any difference.

Where can I get further info of what issue is? Nothing in /var/log/messages


newbuyer17 04-01-2013 10:39 AM

Even more bizarre. I tried moving hdd from slot 3 to slot 4 and it works.
So maybe it is a hardware issue? But I cant understand how a hardware issue would allow me to create ext3 filesystems and use them quite happily, but not LVM volumes?

Any ideas?

All times are GMT -5. The time now is 03:58 AM.