LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 05-30-2003, 02:20 PM   #1
Andrastus
LQ Newbie
 
Registered: May 2003
Posts: 16

Rep: Reputation: 0
vfat partition is read only


I have searched these forums, but all posts I get is about mounting vfat under linux.

I am running RedHat9, and my vfat partition is automounted. That was the easy part. Now my problem is that I use the fat32 partition to share files between my xp installation and RH9. But only root has write access to my vfat partition, and I dont want to use the terminal every time I want to copy some docs to my fat32 partition.

Is there a way to make my vfat partition in linux have read/write access for normal users? I tried chmod, and although that maked the directory have read/write access, as soon as I mount my partition to /mnt/windows, it it read only again for all users except root.

Please keep in mind that I am very new to linux and am not quite familiar with console commands yet.

BTW. Neverwinter Nights runs great. Loadtimes are faster than most players I play with online, and I am on a 56k

Help would be greatly appreciated.

TIA.
 
Old 05-30-2003, 02:24 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
What permissions have you got on the mount point?
ls -l /mnt

What does the line in /etc/fstab look like?
 
Old 05-30-2003, 02:45 PM   #3
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Rep: Reputation: 30
yes, redhat has all the windows partition mounted as read only by default (to set that off, you have to edit the /etc/fstab file - change the lines for those win32 partitions from ro to rw, and umask of 0002 to 0000 and take off the user id.
 
Old 05-30-2003, 03:18 PM   #4
Andrastus
LQ Newbie
 
Registered: May 2003
Posts: 16

Original Poster
Rep: Reputation: 0
I am not currently in redhat, but I think it is something to the effect of:

/dev/hda4 /mnt/windows vfat defaults

I looked at my mount for /mnt/floppy in /etc/fstab and just copied it over and changed the fstype to vfat. It worked but for my small problem.

kazuni: umask and all that is greek to me. I dont have a umask field in /etc/fstab, but thanks for the fast response.

if only I had time to read the docs. I am currently stressed for time because of my semester exams.
 
Old 05-30-2003, 04:25 PM   #5
0x4B
Member
 
Registered: May 2003
Location: Nashville TN, USA
Distribution: Debian (I'm unstable)
Posts: 117

Rep: Reputation: 15
unless you want to mount/umount the windows partition each time you use it, the automounter isn't needed (its good for removable media and network fs). if you have separate partitions for /home or /var you should probably copy one of them, otherwise copy the entry for / . the thing you'll need to change is the last value. its (usually) 0 for things like floppy, 1 for / and >1 for other partitions. the number represents the order in which the partitions are mounted at boot time (and 0 means is isn't). since /mnt/windows relies on /, it needs to be mounted later.
if you set things up so that /mnt/windows is mounted a boot time, then be sure to remove it from the automount system.
(the umask value is an optional argument for vfat, and is set in the 4th column along with things like default,ro/rw, or uid=)
much of this is in the man page for mount, rather than fstab
 
Old 05-30-2003, 04:31 PM   #6
serz
Member
 
Registered: Apr 2003
Location: Buenos Aires, Argentina
Distribution: Slackware, Gentoo
Posts: 397

Rep: Reputation: 30
/dev/hda4 /mnt/windows vfat rw,defaults
 
Old 05-30-2003, 10:11 PM   #7
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
to have full write access to the drive (win partition) do this in your fstab:

dev/hda4 /mnt/windows vfat user,umask=000 0 0

-------------------------------
umask=222 (only read access to the drive)
umask=022 (only root has full write access to the drive)
-------------------------------

Last edited by jt1020; 05-30-2003 at 10:13 PM.
 
Old 06-01-2003, 01:50 AM   #8
Sticks
LQ Newbie
 
Registered: May 2003
Location: South Adrilankha
Distribution: RH9.0
Posts: 5

Rep: Reputation: 0
Unhappy Then again, maybe not

I'm having a problem deleting files from my vfat partition unless I'm logged in as root. (RH9,Win98)

my fstab looks like this:
/dev/hdb1 /mnt/windows vfat rw,auto,owner,users,unmask=000 0 0

Any help is appreciated, it's getting a little old logging in as root every time I need to delete a file

Thanks.
 
Old 06-01-2003, 02:33 AM   #9
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
what files are you deleting?? check the file permisions it might be owned by root....
 
Old 06-01-2003, 03:47 PM   #10
Andrastus
LQ Newbie
 
Registered: May 2003
Posts: 16

Original Poster
Rep: Reputation: 0
/dev/hda4 /mnt/windows vfat user,umask=000 0 0
That did the trick for me.

Thank you.

Last edited by Andrastus; 06-01-2003 at 03:48 PM.
 
Old 06-01-2003, 03:48 PM   #11
0x4B
Member
 
Registered: May 2003
Location: Nashville TN, USA
Distribution: Debian (I'm unstable)
Posts: 117

Rep: Reputation: 15
is there a reason you're using the ower option?
 
Old 06-01-2003, 05:09 PM   #12
Sticks
LQ Newbie
 
Registered: May 2003
Location: South Adrilankha
Distribution: RH9.0
Posts: 5

Rep: Reputation: 0
Sometimes it's the little things

Thanks to all for the help. jt1020 was right, all of the files and directories are indeed owned by root, both as the user and the group. However, that as led to a new problem.

I can't change the permissions. I logged in as root, navigated to /mnt/windows and tried to change the group permission (to a group I already created), but I get an error message saying I don't have sufficient permissions to make the change. I get a similiar error when attempted to chmod the permissions in a terminal.

It doesn't matter whether I try to change a directory or a file, I get the same error. Is this a Win98/vfat issue or am I just missing the big picture?
 
Old 06-01-2003, 10:44 PM   #13
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
Quote:
Originally posted by Andrastus
/dev/hda4 /mnt/windows vfat user,umask=000 0 0
That did the trick for me.

Thank you.
No prob...
 
Old 06-01-2003, 10:50 PM   #14
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
Sticks,

try to change this in your fstab:

/dev/hdb1 /mnt/windows vfat rw,auto,owner,users,umask=000 0 0

to these:

/dev/hdb1 /mnt/windows vfat users,umask=000 0 0

I suggest doing umask=022 so that only root has full write access to your drive, but anyway, be carefull when you delete things in your win partition.....

Last edited by jt1020; 06-02-2003 at 07:38 AM.
 
Old 06-02-2003, 06:42 AM   #15
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
shouldn't it read umask not unmask?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing vfat as read/write rknetsch Linux - General 4 06-17-2005 02:09 PM
fstab vfat read write prob gbarny Linux - General 3 06-20-2004 02:19 AM
Mounting folder in vfat partition as read-only m3rc_2003 Linux - Newbie 2 11-30-2003 02:09 AM
Vfat read-only PrimaryDataLoop Linux - General 8 07-07-2003 10:03 AM
user can't read/write (vfat) partition MykilX Slackware 6 07-04-2003 06:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration