LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Very slow DSL (https://www.linuxquestions.org/questions/linux-general-1/very-slow-dsl-370802/)

urticadioica 10-07-2005 08:18 PM

Very slow DSL
 
After using dialup for several years, I finally got DSL today. The initial setup went fine, and I have a connection through both Linux and Windows. Everything seems to work correctly under Windows, but under Linux, I can only download at about 3 kB/s. Also, I can't connect to any of the four servers I use in gaim (aol, yahoo, msn, jabber).

My provider is Qwest, with MSN Premium (yuck). My modem is an Actiontec GT701-WG. Distro is Ubuntu Hoary. If you need more info, just ask :) Thanks!

jdogpc 10-08-2005 07:54 AM

Your modem is in fact a router with a modem attached acting as a network gateway, so nothing should be wrong, or do you have your router acting as bridge and your machine do the actual connection.
Even if this was the case everything should be ok.

By the way what distro are you using? That could help.

JdogPC

urticadioica 10-08-2005 09:44 AM

Yes, I know it's really a router. There shouldn't be anything wrong, as you said, but there is. The point is, under Windows, on the same machine, I can download over 100 kB/s, while under Linux, I'm downloading at sub-dialup speeds. And then there's the bizarre problem with gaim--I can't connect to any IM services, though I could while I was on dialup. The progress bars stop before they actually connect to the IM servers. If I had an IM client on Windows, I'd tell you if that works, but I don't. I can't imagine my modem or service would block four different ports for IM protocols, nor can I imagine how it could be maliciously slowing my connection on Linux and not Windows.

Perhaps one thing I could mention: this modem has a webserver running on it, and it's connected to my computer with ethernet. When I access the web configuration interface, the speed seems normal, meaning it's probably not a problem with the modem itself or the ethernet. It's a router, as you said, and it also has a DHCP server, and it handles most of the business of connection itself.

It's a bizarre problem, so I appreciate your reply. BTW, I already told you the distro: Ubuntu Hoary.

Thanks!

agtlewis 10-08-2005 07:17 PM

If you have your internet connection misconfigured, your dns servers will constantly be replaced with your gateway ip, ie 192.168.1.1. The best way I have found to set up a dsl modem, is to configure your pc to have a static ip, such as 192.168.1.4, then configure your gateway ip as 192.168.1.1, your dns servers as whatever they are, and then everything should be ok.

Hope that helps but I had a similar problem, I use fedorah 4 now.

urticadioica 10-09-2005 01:08 AM

No, that doesn't seem relevant to the problem. DNS resolution works fine. I just can't get anywhere near a reasonable speed after that's done.

I tried booting into Knoppix and it also had the same problems.

I'm totally lost, so I do appreciate all replies.

urticadioica 10-09-2005 02:10 AM

While doing some troubleshooting, I discovered something even weirder. I tried uploading a 150 kB file to my gmail account, and it took ~2 seconds, roughly what it should be. When I tried to redownload that same file, it got about halfway done after a minute, and then stalled and timed out. Does anyone have ideas as to why Linux, but not Windows, would have horribly slow download speeds, but normal upload speeds? I'm baffled :scratch:

Thanks,

Chris

debian_luva 10-09-2005 11:44 AM

i was able to speed up page loads etc. by disabling ipv6 support on my box...tried that?

i believe it is enabled by default on deb/ubuntu boxes...maybe even all distros.


i haven't been spanked yet for disabling ipv6...YMMV

ralvez 10-09-2005 12:19 PM

... and as per Gaim make sure your router (which likely has firewall rules running) does allows connections to "205.188.8.140:aol".
Hope this helps.

Rick

agtlewis 10-09-2005 01:56 PM

If it's not a dns issue, it's most likely a gateway issue. Post the results from ifconfig. If your modem and your pc are both getting dchp ip addresses something is misconfigured. Log into your modem by typing 192.168.1.1 into your browser and see if it's ip is different than the one assigned to your ethernet card. If it is, and it's not static, your internet connection is misconfigured.

urticadioica 10-09-2005 04:28 PM

Thanks for all the replies!

As for IPV6, I had found these instructions earlier and followed them, without success. I tried again, with the secondary tip at the end of the page (alias net-pf-10 off ipv6), still with no success.

As for gaim, I should have posted it yesterday, but that magically started working with no apparent intervention on my part :scratch:

I checked that my card and my modem had different IPs. The modem's IP is 192.168.0.1, and it is running DHCP. Am I too? Now you're exposing my ignorance :D But anyway, it doesn't look like they have the same IP. Here's the output of ifconfig, without lo for brevity:

eth0 Link encap:Ethernet HWaddr 00:02:2A:C0:AB:1A
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1263 errors:0 dropped:0 overruns:0 frame:0
TX packets:1410 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:834209 (814.6 KiB) TX bytes:205266 (200.4 KiB)
Interrupt:9 Base address:0xd400

Thanks again!

urticadioica 10-10-2005 12:47 AM

I hadn't paid much attention to the possibility of a problem with the network card before. I just took out the network card and installed another I happened to have around. I booted, didn't configure anything, and got a download speed of 136 kB/s. Problem solved! Thanks everyone for your help.

The old card was an Elements 10/100M PCI card, which I can now officially dis-recommend. It was likely using a bad driver.


All times are GMT -5. The time now is 09:52 PM.