-   Linux - General (
-   -   Verizon DSL (

Skidde 12-30-2002 01:30 PM

Verizon DSL
I'm trying to get my laptop working (Slackware 8.1, kernal 2.4.18) with Verizon DSL... it is behind a router, which it seems to be able to access just fine, as it can get an IP address and it can interact with the other computers on the LAN.

The service here is not ADSL, and the PPPOE program I used did not work. When I called Verizon the first time, they linked me to, which is relatively useless as I don't have KDE and the control-panel function does not work (I assume it's KDE independent).

Unfortunately the help Verizon gives is useless... so assistance on this matter would be greatly appreciated.

John Galt 12-30-2002 01:45 PM

Are you using a seperate computer w/ a softrouter installed? Or a standalone hardware router (i.e. linksys router)? If you are using a standalone hardware router then you have no need to establish a PPPoE connection from any of the computers. This will all be taken care of for you by the router. You will need to set it up for the PPPoE connection from within the router. You can access this by typing the router's IP address into the address bar on your browswer. Alternatively some routers allow/require you to telnet into them to set them up. Either way this is where you will set up your PPPoE connection.

trickykid 12-30-2002 01:47 PM

If your on this laptop and not behind your router currently, look into getting Roaring Penguin for pppoe connections.

Skidde 12-30-2002 02:05 PM

I used Roaring Penguin, that was the program I was referring to when I said "PPPoE program."

Also the router is a linksys router, but when it tries to connect it claims it cannot find a PPPoE server.

The last person I spoke to on the phone only served to confuse me further and tersely remark that it was a router problem, and wasn't because of the DSL.

Update: I tried to use the Roaring Penguin program again... this time it says it can connect, but when I try to open a page, it fails miserably after timing out. Also, the IP address that the laptop is reporting it has (public) varies... but the one returned by adsl-status has the last numbers wrong.

John Galt 12-30-2002 03:07 PM

the router should be able to connect to the PPPoE server w/o a problem. You won't be able to use PPPoE software from behind the router so if your dead set on using a hardware router I'd give up the idea of software and concentrate on why the router won't connect. You need to verify all your settings within the router. Always double check those. Make sure you have the correct DNS servers from your ISP (this won't fix your problem but if you have to call them anyway to verify the settings you might as well verify them all). Double check the server address that you are connecting to and finally double check your username and password. Also you must provide a host name if your ISP requires it (most don't). If this is the case you must find out from your ISP what host name to use. If it still doesn't work and you are sure the router is not bad then the problem lies w/ your DSL line. I have setup DSL probably about 100 times or so. I think maybe 5 of those went smoothly with no problems regarding the line. Every other time I am always on the phone with them while they fix the problem.

Have they installed a splitter on your line? If they have not then you must use a DSL filter for all voice lines you intend to use (i.e. phone, fax, etc). Make sure you have not installed a DSL filter on the DSL line itself or you will be filtering the DSL signal from reaching the modem. Most modems have several lights on the front. These lights can give insight if there is a problem with the line. Usually its 4 lights. One is a LAN link light, one is a WAN link light, the other 2 are power and sys (yours may vary). Please ensure that all lights that should be on ARE on..but the 2 important ones are the WAN and LAN link lights. You have apparently gotten the router to work on the LAN so that should be lit up. make sure the WAN link is litup. If it is not and everything is connected properly then get back on the phone cause the problem is with the line and not with the router or computer.

All times are GMT -5. The time now is 06:55 PM.