-   Linux - General (
-   -   usb modem not recognized (

PAB 06-29-2003 09:01 PM

usb modem not recognized
I have installed Redhat 8.0 and my creative modem blaster (usb) does not seem to be recognized. In the information section of the Red Hat Control, it lists it as on the USB port, but when I try to set up the internet, it either says the modem cannot be found or it is busy. i have tried every port available in the settings, and nothing works. in windows, i would be able to fix this without any problem by using the control panel. not being too knowledgeable about linux, i don't know how to setup a modem.

any help will be appreciated.

Thymox 06-30-2003 06:44 PM

Just as the PCI bus is fast enough for data to be passed to the computer for processing, rather than having lots of 'expensive' chips on the modem itself, so is the USB bus. Often, even though they are external modems, USB modems are software modems too - just like the ubiquitous Winmodems.

You could try checking out for links to how to identify if you have a winmodem, and which are working. I know how annoying it can be - I bought a USB modem that I thought would work, but it turns out that there are two revisions my modem, and only one of them works (even that is a bit dicey, apparently), and mine is the other one! If your modem is listed as not working with Linux, then I would suggest you sell it on to someone else and buy yourself an external serial modem.

PAB 07-02-2003 12:48 PM

thanks for your reply. i actually got it to work. i am not sure what any of the commands really mean, but i had to create a symbolic link from ttyACM0 to /dev/modem. i have the code if anyone wants me to send it to them or post it here.

thanks again

cyberhawk 07-05-2003 03:35 AM

i have a similar problem with my modem not being recognized. but i dont have a /dev/usb/tts/ACM0 device mine just has /dev/usb/tts/0 how do i get an ACM0 device setup and how would i create a link to /dev/modem. as you can see i am still a newbie so i don't know much


PAB 07-05-2003 02:40 PM

This is what I typed to get my Modem to work:

rm /dev/modem (may not matter if you don't already have this, but type it anyway)

cd /dev
mknod ttyACM0 c 166 0
mknod ttyACM1 c 166 1
mknod ttyACM2 c 166 2
mknod ttyACM3 c 166 3

(While still in /dev)
ln s ttyACM0 modem (this creates the link)

then change the settings in KPPP to /dev/modem, and then connect in KPPP.

My understanding (limited at best at this point) is that this only will work in KDE and not GNOME. I am not sure if this is true. Let me know if it works for you.


All times are GMT -5. The time now is 01:11 PM.