-   Linux - General (
-   -   (URGENT) Fedora Core 6 - Could not find logical volume "VolGroup00" (

linxnoob 07-07-2007 02:57 AM

(URGENT) Fedora Core 6 - Could not find logical volume "VolGroup00"

I'm running FC6, on a P4 3.0Ghz server with 2 x 320GB HDD
running mirroring raid using RocketRaid (Highpoint brand) 1520 raid card.

Suddenly last night, there were some errors on the server such as unable
to write to I/O. The server was rebooted and during Fedora bootup, there
is an error saying it couldnt find any logical volumes groups.

Could not find logical volume "VolGroup00" which i believe is my raid drives..
then it says cant find /dev/root etc
then it gives kernel panic..

Scanning logical volumes
No volume groups found
Activating logical volumes
Volume group "VolGroup00" not found
Trying to resume from /dev/VolGroup00/LogVol01
Unable to access resume device /dev/VolGroup00/LogVol01
Creating root device
Mounting root filesystem
mount: could not find the system "/dev/root/"
Setting up other filesystems
Setting up new root fs
setuproot: moving /dev/failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel Panic - not syncing: attempted to kill init

My boot up arguments for grub is
Grub version 0.97
Fedora Core (2.6.20-1.2925.fc6)
grub append> ro root=/dev/VolGroup00/LogVol00 hde=noprobe hdf=noprobe hdg=noprobe hdf=noprobe

I tried booting individual drives but the same error occurs.

What should I do? as the files are critical inside.

saikee 07-07-2007 04:04 AM

How about asking Grub in Grub prompt "tell me what you see in my disk" by

geometry (hd0)
geometry (hd1)

If it is a mirror RAID and the one boots has been corrupted (say the bearing wears out first) then it can give you the kind of problem as reported. You can also investigate "gently" by pop in a Live CD to mount the drive (or drives) to check if all the data are inside.

At this stage your data should be secure but I would be reluctant to write things on it until I clone the disk first if the data inside is critical.

I believe the idea of the mirror RAID is if you have a defective disk, remove it thereby break up the RAID the remaining disk should operate normally. Not an experienced RAID or LVM user myself though.

linxnoob 07-07-2007 04:32 AM


I ran individual disks one by one and both have the same error each time.
I dont have Live CD, and below is the geometry:

drive 0x80: C/H/S = 1024/255/63, the number of sectors = 625142447, LBA
Partition num:0, Filesystem type is ext2fs, partition type 0x83
Partition num:1, Filesystem type is unknown, partition type 0x8e


Error 21: Selected disk does not exist


That is what i got

What should I do now?

saikee 07-07-2007 06:36 AM

You can at the Grub prompt test which disk Grub couldn't find.

So far Grub confirm (hd0) exists.

You have two partitions (hd0,0) and (hd0,1). The first has to be your /boot for the Red Hat as the second is type 8e signifying a LVM which no Linux boot loader can read (thats why a separate /boot is necessary). Grub's files, Red Hat kernels and initrd files will be in /boot. Therefore you ask Grub to display the menu.lst (or grub.conf which is symbolic link to menu.lst) by

cat (hd0,0)/grub/grub.conf
You then follow each line and type it at the terminal, starting with the "root" statement.

Post the grub.conf and report which line Grub is having a problem.

All times are GMT -5. The time now is 09:36 PM.