LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 12-05-2008, 01:48 AM   #1
Dr_Death_UAE
Member
 
Registered: Jul 2005
Location: U.A.E
Distribution: FreeBSD,Fedora,Solaris,AIX
Posts: 168

Rep: Reputation: 30
upgrade from Fedora 9 to 10, Missing Dependency


Hello, i was trying to upgrade from fedora 9 to 10 with yum, and i got this error after running
rpm -Uhv http://mirror.liberty.edu/pub/fedora...0-1.noarch.rpm http://mirror.liberty.edu/pub/fedora...0-1.noarch.rpm

yum clean all

yum -y upgrade

Quote:
--> Finished Dependency Resolution
nautilus-2.22.4-1.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libgnome-desktop-2.so.2 is needed by package nautilus-2.22.4-1.fc9.i386 (installed)
gnome-panel-2.22.2-2.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libgnome-desktop-2.so.2 is needed by package gnome-panel-2.22.2-2.fc9.i386 (installed)
gnome-panel-2.22.2-2.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libedataserver-1.2.so.9 is needed by package gnome-panel-2.22.2-2.fc9.i386 (installed)
compiz-gnome-0.7.7-10.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libgnome-desktop-2.so.2 is needed by package compiz-gnome-0.7.7-10.fc9.i386 (installed)
gnome-panel-2.22.2-1.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libedataserver-1.2.so.9 is needed by package gnome-panel-2.22.2-1.fc9.i386 (installed)
libkexiv2-0.1.7-1.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libexiv2.so.2 is needed by package libkexiv2-0.1.7-1.fc9.i386 (installed)
gnome-panel-2.22.2-1.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libgnome-desktop-2.so.2 is needed by package gnome-panel-2.22.2-1.fc9.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.2 is needed by package nautilus-2.22.4-1.fc9.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.2 is needed by package gnome-panel-2.22.2-2.fc9.i386 (installed)
Error: Missing Dependency: libedataserver-1.2.so.9 is needed by package gnome-panel-2.22.2-1.fc9.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.2 is needed by package compiz-gnome-0.7.7-10.fc9.i386 (installed)
Error: Missing Dependency: libexiv2.so.2 is needed by package libkexiv2-0.1.7-1.fc9.i386 (installed)
Error: Missing Dependency: libgnome-desktop-2.so.2 is needed by package gnome-panel-2.22.2-1.fc9.i386 (installed)
Error: Missing Dependency: libedataserver-1.2.so.9 is needed by package gnome-panel-2.22.2-2.fc9.i386 (installed)

do i have to remove gnome-panel, compiz-gnome, nautilus and libkexiv ?

I also try to use preupgrade, but i already install fedora release 10 package so preupgrade just showing me Rawhide release.
 
Old 12-05-2008, 05:39 PM   #2
Dr_Death_UAE
Member
 
Registered: Jul 2005
Location: U.A.E
Distribution: FreeBSD,Fedora,Solaris,AIX
Posts: 168

Original Poster
Rep: Reputation: 30
i solve the issue, i found that some of my linux packages have old and new version in the same time:

[root@drdeath drdeath]# rpm -qa | grep compiz-gnome
compiz-gnome-0.7.9-3.fc9.i386
compiz-gnome-0.7.7-10.fc9.i386


i remove the old packages with yum remove, and now i am able to continue my upgrade.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Dependency saurabhvasa Linux - Software 2 08-27-2008 10:24 AM
fedora update problem: Missing dependency gecko-libs gyc Fedora 11 07-22-2008 12:04 PM
Missing dependency updating compiz-fusion on Fedora 8 tron_thomas Linux - Software 2 11-12-2007 11:44 AM
PHP5 Upgrade Error: Missing Dependency: php = 4.3.x is needed by package php-pear vsystems Linux - Server 1 05-02-2007 07:17 AM
Missing Dependency for libquicktime jborn Linux - General 1 06-25-2006 09:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration