LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   unmounting my usb drive (https://www.linuxquestions.org/questions/linux-general-1/unmounting-my-usb-drive-62180/)

flinchumj 05-27-2003 07:30 PM

unmounting my usb drive
 
ok....i guess this is a noob question...

i got my usb drive to hotplug, and it mounts onto my desktop with me as the owner (i used UID=(my uid)), but it wont let me unmount it unless i am root. Are there some other options i can use to unmount the drive without invoking root priviledges.:confused: I tried the user,uid, and dev options, but they dont seem to be working. any help is much 'preciated.

ranger_nemo 05-27-2003 07:37 PM

Oops... Maybe I should have read your question a bit closer. I suggested adding the user option into the /etc/fstab .

It might have something to do with the automounter. Maybe try disabling it and manually mounting / umounting.

0x4B 05-28-2003 12:20 PM

you might want to replace user with users. the first lets anyone mount, but the same person has control over the device. the second should let anyone unmount it
(I'm assuming that the automounter is mounting the device as a user different from yours. I'm also assuming its automounting, correct me if not)

Pcghost 05-28-2003 12:58 PM

what is the error message when you do a
umount /dev/sda <--- Assuming thumbdrive is an sda

flinchumj 05-29-2003 08:17 AM

the users option didnt help
when i try unmounting with /dev/sda1, it says 'only root can unmount /dev/sda1..."

flinchumj 05-29-2003 08:28 AM

ok i changed the order of the options from
rw,dev,exec,uid=500,noauto,users
to
rw,users,dev,exec,uid=500,noauto
and it worked, i read users automatically implies noexec,nosuid,nodev, and so i guess having it at the end of the line canceled out dev....or something like that. but it works! thanx

0x4B 05-29-2003 10:16 AM

I hadn't noticed it earlier, but the man page does say
unless overridden by _subsequent_ options, as in the option line user,exec,dev,suid
stupid linear parsing ;)


All times are GMT -5. The time now is 11:43 PM.