-   Linux - General (
-   -   Unknown System Crashes (

Darkhack 06-30-2006 06:24 PM

Unknown System Crashes
I seem to be having a strange problem with my system crashing. When it crashes the entire screen changes. The graphics chip seems to be outputting junk data. The screen either turns one solid color or it displays a pattern of some kind like vertical stripes. When this happens I am forced to do a hard reboot. I can't restart X, nor can I F1 to a shell nor does ctrl-alt-del work. At first I thought it was the graphics driver. I updated it to the latest version and the problem still exists. I then updated my kernel and still it persists to crash. The crashes occur every couple of days. The only connection I have found between them is that they occur directly after a page has finished loading in Firefox. It's not a script on the page because this can occur on any page even plain HTML ones. But it occurs a split second after a page loads. The system logs don't show anything had happened other than logging the occurance of a reboot itself, but no error messages. Here is my information...

Distrobution: Kanotix - 32 bit (Based on Debian Unstable)
Kernel: 2.6.17
Graphics: ATI xpress 200 (RS480 5954)
Driver: ATI 8.25.18
Boot Parameters: /boot/vmlinuz root=/dev/hda4 ro ramdisk_size=100000 lang=us apm=power-off nomce vga=0x317 pci=routeirq noapic acpi=off irqpoll
Hardware: Emachines T6212 - AMD Athlon64 3200+ 2.0ghz

Note: The kernel parameters listed above are required or else the system either won't boot or it won't detect all of my hardware due to IRQ issues.

I realize that with such little information that this thread will probebly recieve zero replies and end up in oblivion. Although if anyone has even the slightest idea about what might be atleast causing it, it would be appreciated. I'll try using the Radeon driver for a while and see if the crashes still occur. Even though I updated the ATI drivers that still might be a bug they haven't fixed. Thank you for taking the time to read my thread.

pjbgravely 06-30-2006 10:10 PM

I have been working on the same problem, but mine is with Ubuntu, even worse every time I fix something it works fine for several days then starts to crash again. It is probably a hardware problem, start with running memtest86, Try running it with Knoppix, if that crashes you know it is a hardware problem. Mine never crashed with Knoppix, but it was a good test. I did find a bad file system, and have changed mice. My last repair was to change the power supply. The computer now feels faster, so I may have found the problem at last. A software problem should give you an error or a kernel panic. Also try re-seating your processor and cards. Let me know what you find.


Darkhack 06-30-2006 11:38 PM

The crashes I am expierencing never happened on Windows XP. They happen every 2-3 days on Linux yet I can have Windows up for weeks. It has got to be a problem with the kernel or the drivers. I'll see what I can do about filing a bug report. I am sure there is some geeky kernel developer out their that knows something about this.

pjbgravely 07-01-2006 12:22 AM

Then try Knoppix first, if it doesn't crash on that then try a different kernel on your system. It may be a bad driver, so make sure you aren't running any closed source ones. I have had bad partitions cause spontaneous reboots too, so check them with fsck in Knoppix. If all else fails you can try a diffrent distro.

khaleel5000 07-01-2006 09:18 AM

y dont you try browsing on other browsers like konqueror itself and see if you still experience the same problem?

gzickert 07-01-2006 11:59 AM

Unknown System Crashes
I have also been experiencing this same crash scenario on a new Dell E510 w/ATI Radeon graphics run Fedora Core 5 and the latest updates. It seems to occur when I run Fire Fox. I get messed up graphics in all programs there after until the system locks. A power off is the only way to recover.

Emerson 07-01-2006 02:26 PM

First, you should get rid of those ugly options in kernel command line. They may be necessary for install but later you should build an appropriate kernel. Turning APIC off will give you IRQ trouble.
Second, to diagnose this problem try using Xorg radeon and/or vesa drivers instead of ATI one.

darrellc 07-06-2006 09:48 PM

Random crashes
For what it's worth, I had similar problems with my Debian Etch machine and nVidia graphics card(s) for a month. I finally found that I could cause a crash every time I ran certain OpenGL screen savers. It would also still crash randomly. I could switch to vesa drivers or the standard nv driver and the system would not crash. I tried older drivers. I tried different nVidia cards. I tried live CD's. Same problem. Still seemed to be related to the accelerated graphics card or drivers. After pulling most of my hair out, fate finally stepped in. The computer crashed and I could not get it back up. Further investigation found swollen capacitors on the motherboard and a burned up power supply (smells real bad). Don't know which one took out the other, but I am now the proud owner of a new Sempron 64 motherboard and power supply, running the same memory, hard drive with existing Debian Etch installation, graphics card and drivers, and have had no problems since. It's a lot faster too!

gzickert 07-07-2006 07:47 PM

System crash
I just downloaded and installed xorg-x11-drv-ati- and it fixed the problem on my machine. Perhaps upgrading your xorg-x11-drv... will resolve your problem too. Good luck.

haertig 07-07-2006 08:16 PM

My similar problem was ATI graphics card hardware. I would see freezes and such in Linux, but when dual-booted back to Windows to test it there I'd see "GPU Recovery" popups after the freezes. I RMA-ed the ATI board and replaced it with an nVidia (better support under Linux anyway, IMHO). All the problems went away with the new graphics hardware. I was using the vesa driver with the ATI under Linux, but an ATI accellerated driver under Windows. I haven't had to use the Windows dual-boot since, but in this specific case Windows did help me isolate the problem to graphics hardware. As much as I hate to admit that.

All times are GMT -5. The time now is 05:55 AM.