-   Linux - General (
-   -   Unable to read certain files from CD, but works on Windows (

DoubleLetter 05-15-2002 12:42 AM

Unable to read certain files from CD, but works on Windows

I have a collection of some 97 mp3s on a CD, burned by a friend.

It is a Imation CD burned using HP CD WRITER.

Windows (installed on a seperate machine) copies all files from the CD perfectly to the hard disk, without any error.
However, on Linux, 26 mp3s are only half copied because of an "Input/Output error (5)". The CD is unscratched & unsmudged. And my cdrom on the linux machine is 40X.

Can anybody explain why this is so ?

THe cdwriter wrote an image of iso9660, that same that Linux requires.

Any help is deeply appreciated,



MasterC 05-15-2002 01:53 AM

Do you have the HD on the same IDE channel as the CDROM? I used to get some errors when I did, I simply put them on separate IDE cables, and viola! No more errors. Since windows is on a separate machine, maybe this is not the setup of the other machine. Check that out, I think you may be happy with the results.

l_9_l 05-15-2002 01:53 AM

may(5%) :D the kernel need the joliet fs to copy them

try this may will help:
# dd if=/dev/cdrom of=~/image.iso
will take a while and you will see image.iso at your home dir.
# mkdir ~/97mp3 :D
# mount -t iso9660 -o loop=/dev/loop0 ~/image.iso /mnt/cdrom
# cp -a /mnt/cdrom/* ~/97mp3
# rm ~/image.iso

DoubleLetter 05-15-2002 02:14 AM

But it never
Thanks for the reply,

I wonder why, if there was a HDE problem, it would only occur on THIS CD. All other cds that (other) friends have burned for me on Windows have worked perfectly !!

MasterC 05-15-2002 02:47 AM

Maybe you need new friends. Teach them the ways of the Linux. Make them join the dark side. Use your mind tricks. Do not let them believe they are using their computers to it's fullest.

Or maybe the CD wasn't finalized.

DoubleLetter 05-15-2002 06:54 AM


What is finalizing a CD ?


I tried the suggestion of "l_9_l", but even 'dd' says "input output error".



Rashkae 05-15-2002 08:13 AM

Oh Sheesh,, Obviously, the CD-ROM of your Linux compuer is unable to read the recorded CD, whereas the CD-rom in the separate Windows Machine can,, if you really want to test this, swap the CD-ROM drives.

DoubleLetter 05-15-2002 08:41 AM

I stress again:

26 mp3s are not being read properly; the rest are. I copied the maining 71 mp3s perfectly to my hard drive.

The CD is not damaged either.



DoubleLetter 04-21-2003 11:40 PM

I solved the problem !

The CD that Linux was misreading was written in the UDF filesystem (using an obscure CD writing software that didn't support other filesystems) !

Linux did not automatically detect it was UDF, and automounted it as the iso9660 fs.

We can solve this by mount it specifically as udf ( mount -t udf ...); however, reading from the udf fs on linux is very slow...

Well, at least, those mp3s weren't lost !


Regards, Ahsan

MasterC 04-22-2003 01:20 AM

ha ha ha, nearly a year later :D


DoubleLetter 04-22-2003 01:56 AM

:) Various reasons, the main reason being I had not burned the CD myself....

All times are GMT -5. The time now is 08:04 AM.