LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Closed Thread
  Search this Thread
Old 05-06-2015, 04:20 AM   #1
-Soufiane-
LQ Newbie
 
Registered: May 2013
Location: France
Posts: 14

Rep: Reputation: Disabled
Unable to boot on virtual machine using Extlinux bootloader


I use a bash script that automatically generates a debian virtual machine installed on a virtual disk image. The original bootloader is grub2 , but I want to use extlinux instead so added it to the script. yet it installs without errors and configuration files are generated correctly, but when starting it is as if there were no bootloader and the virtual machine does not boot.
The disc is an NBD block device associated with a loopback module, so I try to use the loop module UUID in /boot/extlinux/linux.cfg configuration.

Here are the commands that are executed by the script:

sed -i -e 's / initrd = \ / boot \ /initrd.img-3.2.0-4-amd64/initrd = \ / boot \ /initrd.img-3.2.0-4-amd64 root = UUID = `blkid | egrep '/dev/loop.*' | cut -d "" -f 2` / g '/boot/extlinux/linux.cfg

extlinux --install / boot / extlinux /

The script is called genvm and is located at:
http://sourceforge.net/projects/genvm/

Can anyone please provide me with explanation or guidance to address this issue ?
 
Old 05-07-2015, 08:13 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,661
Blog Entries: 36

Rep: Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857Reputation: 2857
Moderator response

Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate of http://www.linuxquestions.org/questi...9/#post5359054
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to ping from virtual machine pugazhendhi_r@yahoo.com Linux - Virtualization and Cloud 2 01-08-2015 06:36 PM
[SOLVED] How to start Grub2-bootloader from extlinux-bootloader? floppy_stuttgart Linux - Newbie 13 11-13-2011 06:43 PM
[SOLVED] grub as bootloader on partition within vmware virtual machine poly_s Linux - Virtualization and Cloud 5 11-12-2011 05:39 AM
unable to auto mount 'shared folder' iin Suse 11.2 virtual machine using Virtual Box marvinudy Linux - Virtualization and Cloud 1 02-03-2010 02:29 PM
Unable to start virtual machine satimis Linux - Server 7 12-19-2007 11:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 02:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration