LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 04-04-2013, 02:33 AM   #1
cent_sangeeta
LQ Newbie
 
Registered: Sep 2012
Location: kathmandu,Nepal
Posts: 22

Rep: Reputation: Disabled
unable to access internet in my machine


Dear all,
My machine is unable to access internet.I am using Centos6.3
My ifconfig information is as follows.

eth0 Link encap:Ethernet HWaddr 00:30:481:6D:4E
inet addr:192.168.0.19 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::230:48ff:fed1:6d4e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:286 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2408 (2.3 KiB) TX bytes:20370 (19.8 KiB)
Interrupt:18 Memory:d8020000-d8040000

eth1 Link encap:Ethernet HWaddr 00:30:481:6D:4F
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:19 Memory:d8060000-d8080000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:726 errors:0 dropped:0 overruns:0 frame:0
TX packets:726 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:60774 (59.3 KiB) TX bytes:60774 (59.3 KiB)

I don't know but my of my friend suggests that I have to remove "inet addr:192.168.0.19 in eth0". Is it true? I would appreciate any help on it.

Sangeeta Maharjan.
 
Old 04-04-2013, 04:45 AM   #2
hurryi
Member
 
Registered: Apr 2010
Distribution: RHEL
Posts: 77

Rep: Reputation: 6
well this is very few information

I can see you have 2 interfaces
eth0 with ip/subnet

what about your routing table?
is a default gateway defined? can you reach it?

is the ip was assinged with dhcp or you manually configured the ip?
do you have link for those interface(s)

could you please provide output for the following commands?

route -n
ethtool eth0
ethtool eth1
cat <path>/ifcfg-eth0
 
Old 04-04-2013, 06:01 AM   #3
gangadhar402
Member
 
Registered: Mar 2013
Location: the India
Distribution: Ubuntu,Debian and CentOS
Posts: 35

Rep: Reputation: 2
Hi,

http://www.vhdesigns.com/how-to-conf...-linux-server/

this will helpful
 
Old 04-05-2013, 03:15 AM   #4
cent_sangeeta
LQ Newbie
 
Registered: Sep 2012
Location: kathmandu,Nepal
Posts: 22

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hurryi View Post
well this is very few information

I can see you have 2 interfaces
eth0 with ip/subnet

what about your routing table?
is a default gateway defined? can you reach it?

is the ip was assinged with dhcp or you manually configured the ip?
do you have link for those interface(s)

could you please provide output for the following commands?

route -n
ethtool eth0
ethtool eth1
cat <path>/ifcfg-eth0
Hi,thanks for reply. The output of the commands are,
Code:
1.route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
Code:
2.ethtool eth0
Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Speed: Unknown!
	Duplex: Unknown! (255)
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000001 (1)
	Link detected: no
Code:
3.ethtool eth1

Settings for eth1:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Speed: Unknown!
	Duplex: Unknown! (255)
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000001 (1)
	Link detected: no
Code:
4.cat/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
BOOTPROTO=none
NM_CONTROLLED="yes"
ONBOOT=yes
TYPE="Ethernet"
UUID="aaaec3fd-c964-4d9c-bf9a-ea87211e0491"
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"
HWADDR=00:30:48:D1:6D:4E
IPADDR=192.168.0.19
PREFIX=24
GATEWAY=192.168.0.1
DNS1=8.8.8.8
LAST_CONNECT=1362742393
Thank you.
Sangeeta Maharjan.

Last edited by onebuck; 04-09-2013 at 09:55 PM. Reason: clean post by using vbcode tags.
 
Old 04-05-2013, 06:34 AM   #5
hurryi
Member
 
Registered: Apr 2010
Distribution: RHEL
Posts: 77

Rep: Reputation: 6
well link detected no is definetly a problem there

is teh cable plugged in?
 
Old 04-09-2013, 01:21 AM   #6
cent_sangeeta
LQ Newbie
 
Registered: Sep 2012
Location: kathmandu,Nepal
Posts: 22

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hurryi View Post
well link detected no is definetly a problem there

is teh cable plugged in?
hi,
Last time the cable was not plugged in. I simply plug the cable and execute those command again.
Code:
1.route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
Code:
2.ethtool eth0
Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Speed: 1000Mb/s
	Duplex: Full
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: off
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000001 (1)
	Link detected: yes
Code:
3.eththool eth1

Settings for eth1:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Speed: Unknown!
	Duplex: Unknown! (255)
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000001 (1)
	Link detected: no
4.cat <>/ifcfg-eth0DEVICE="eth0"
BOOTPROTO=none
NM_CONTROLLED="yes"
ONBOOT=yes
TYPE="Ethernet"
UUID="aaaec3fd-c964-4d9c-bf9a-ea87211e0491"
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"
HWADDR=00:30:48:D1:6D:4E
IPADDR=192.168.0.19
PREFIX=24
GATEWAY=192.168.0.1
DNS1=8.8.8.8
LAST_CONNECT=1362742393
Thank you.

Sangeeta Maharjan.

Last edited by onebuck; 04-09-2013 at 09:53 PM. Reason: clean post by using vbcode tags.
 
Old 04-10-2013, 08:24 AM   #7
hurryi
Member
 
Registered: Apr 2010
Distribution: RHEL
Posts: 77

Rep: Reputation: 6
thats good
is that solved your problem?
as you did not marked it as solved but nor you provided that you still have issues
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Virtual Machine cannot access the internet \/4A Linux - Virtualization and Cloud 6 09-20-2012 01:59 AM
virt-machine access to internet bilux Linux - Virtualization and Cloud 4 08-04-2011 07:29 PM
Machine access over internet is very slow.. vks_agra Linux - Networking 1 12-16-2005 12:45 PM
unable to access machine on same router Harpune Linux - Networking 1 11-05-2005 01:22 AM
configuring machine for internet access duenasg Linux - Networking 6 01-06-2005 02:00 PM


All times are GMT -5. The time now is 08:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration