-   Linux - General (
-   -   Un-removable package??? (

Slimmay 08-08-2008 03:51 PM

Un-removable package???
Ok, I am running my EEE PC 701 off of Xandros, and I removed UnionFs and merged the first two partitions and have been trying to free up some space. I removed the Open Office suite and I then tried to remove "asus-ooo-writer". It came up with:

/home/user> sudo apt-get remove asus-ooo-writer
Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 108 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 61.3MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 73242 files and directories currently installed.)
Removing asus-ooo-writer ...
dpkg-divert: mismatch on divert-to
when removing `diversion of /usr/share/applications/ooo-writer.desktop to /usr/share/applications/ooo-writer.desktop-orig by asus-ooo-writer'
found `diversion of /usr/share/applications/ooo-writer.desktop to /usr/share/applications/ooo-writer.desktop.orig by asus-ooo-writer'
dpkg: error processing asus-ooo-writer (--remove):
subprocess post-removal script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Every time I try to remove a package now, it thinks I'm trying to remove asus-ooo-writer along with it! I went into synaptic and tried to unmark it but it doesn't work! any suggestions!?


jailbait 08-08-2008 04:31 PM

It looks like your package manager files may be messed up. Try using dpkg to straighten out the files:

sudo dpkg --configure -a

sudo dpkg --audit


man dpkg

Steve Stites

klearview 08-08-2008 04:37 PM

Looks like a package removal script bug to me. I had a similar problem LONG time ago - iirc a remove script that needs to be corrected is in /var/lib/dpkg/info .

Slimmay 08-09-2008 08:44 AM

RE: Un-removable package???
sudo dpkg --configure -a does nothing

sudo dpkg --audit shows me that asus-ooo-writer is half installed

man dpkg suggests --purge and --remove BUT nothing seems to work!

Is there no way to fix this problem?

klearview 08-09-2008 09:32 AM

Hello again,

From what I can see from your first post in the error you quote dpkg expects to find '/usr/share/applications/ooo-writer.desktop-orig' in the removal script but instead finds '/usr/share/applications/ooo-writer.desktop.orig' .

If I remember correctly (keep in mind though that I had a similar problem a long, long time ago and I might be wrong) the trick is to fix the script first and then run 'apt-get install -f' as root. The script will be in /var/lib/dpkg/info ,probably under name asus-ooo-writer.postrm

estabroo 08-09-2008 10:13 AM

You need to manually remove the divert.

(to see the diversions)
dpkg-divert --list

use dpkg-divert --remove to remove the diversion. If it still complains you can add (dpkg-divert --add) in the diversion its expecting.

Slimmay 08-09-2008 11:51 AM

Wow, that worked, now the package is completely gone, but I don't care! Thank you all who have posted, but it was 'estabroo' who's idea worked.

All times are GMT -5. The time now is 01:25 PM.