-   Linux - General (
-   -   ulimit (

spivy66 01-10-2008 08:19 PM

Hey All

I have a problem with a user other then root. I'm trying to set ulimit -n 20000 in my .bashrc or even my .bash_profile for that user but everytime i log off it tells me I don't have permission. How can I have this save on boot?...

-bash: ulimit: open files: cannot modify limit: Operation not permitted

sydney-troz 01-10-2008 11:01 PM

are you modifying the file as root? you probably won't have write access as a normal user to another user's home directory, so you'll need to use sudo or log in as root and modify the file from there.

spivy66 01-11-2008 07:08 AM

Thank you for your reply,and yes i tried using sudo but haveing issues setting it up in the the suoders file.I a tried to add

notes ALL=(ALL) ALL

and then added ulimit -n 20000 in my .bash_profile but that didnt work, any help would be great.thanks

spivy66 01-11-2008 07:13 AM

correction i added

sudo notes ALL=(ALL) ALL

sydney-troz 01-11-2008 09:19 AM

so you have the word "sudo" in your sudoers file? and we're assuming your user is "notes".


notes ALL=(ALL) ALL
should be all you need.

spivy66 01-11-2008 11:03 AM

That might be my problem and yes notes is the user..Here is my suoders file.. I don think I have sudo in there..where do i put it?thanks for your help

# Host alias specification
# User alias specification

# Cmnd alias specification

# Defaults specification

# User privilege specification
root ALL=(ALL) ALL
notes ALL=(ALL) ALL
# Uncomment to allow people in group wheel to run all commands
# %wheel ALL=(ALL) ALL

# Same thing without a password

# Samples
# %users ALL=/sbin/mount /cdrom,/sbin/umount /cdrom
# %users localhost=/sbin/shutdown -h now

spivy66 01-11-2008 02:33 PM

I figured it out, thanks for your help. It turned out that i needed to make some changes to my limits.conf file

All times are GMT -5. The time now is 12:03 PM.