-   Linux - General (
-   -   Two monitors output mapped into one. (

theDigitalAngel 06-11-2009 11:31 AM

Two monitors output mapped into one.
2 Attachment(s)
I have been facing a really weird problem.

What Happens

After I start up when I try to maximize any application window, instead of maximizing to the full 1280x800 I get a maximized window spanning 1024x768. However if I move the window around to make it aware that this is actually a 1280x800 display, the window maximizes properly.

What all I have tried.

I have tried using both gnome and XFCE and this problem persists. When I tried using XFCE I found out something really interesting - somehow the 1024x768 output of my projector/TV out and the 1280x800 display of my video card (Intel GM965/GL960) are BOTH getting mapped to my LCD monitor. Have a look at the screenshot I have attached. I can even independently set the wallpaper of the two monitors. Even lspci | grep -i graphics gives two outputs:


00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

I initially though this to be an problem and tried fiddling with xorg.conf but it did not help. Am attaching my current xorg.conf as xorg.conf.txt.

Currently I am using the i915 driver. Using the i830 driver solves the above problem but a) The framebuffer does not work, b) OpenGL does not work - both expected because the real driver for my device is actually the i915. Even when I link both the drivers as modules I uevent loads i915.

What may be the problem.

I think there may be

a) A problem in the i915 driver itself but then that would have to be a fairly recent bug since Ubuntu 8.10 did not have this problem.

b) More likely something wrong my xorg.conf. Is there a way to specify multiple displays exist and map only one of them to the LCD output?

I am currently using Arch Linux. I do not use the stock kernel but a compiled

Any help / pointers / links will be a appreciated.

PS. If you use Acer 4720z or anything similar please upload your xorg.conf. That would be of great help.

archtoad6 10-30-2010 08:30 AM

Did you mean to mark this "[SOLVED]"?

If so, kindly post the solution -- even though this is an old post, it still might help someone else w/ the same, or a similar, problem.

BTW, nicely structured question -- I like the bold headings. Personally, I tend toward underling; but both accomplish the same thing. Rep to you.

All times are GMT -5. The time now is 11:39 AM.