LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   tux racer (https://www.linuxquestions.org/questions/linux-general-1/tux-racer-14990/)

biophysics 02-24-2002 07:27 AM

tux racer
 
Hi
In continuation of my question on why tux racer is slow

I want to know how do I improve the performance of Hardware accelerators, where to configure

thanks

neo77777 02-24-2002 10:32 AM

Where is your question?
Quote:

In continuation of my question on why tux racer is slow
tell us more about your hardware, what graphics card do you use, what version of XFree86?

320mb 05-19-2003 08:30 PM

Sorry for bringing up an old post, Was looking for some sort of perfomance standard as far as frames per second while playing tux racer or any other games that require 3d acceleration.................After 8 months of frustration I finally got GLX working properly......ye haw......I got tux demo for now.
fired up glxgears and then played a race or two and it seems to average 2300 fps or so. this box is an P3 850 chip, 32 meg Anihilator2 video card, 5.1 SB live. Everything works and sounds GREAT. Cool game, gonna buy full version next week!! Just curious what others out there have to say.

crusheroz 05-19-2003 11:43 PM

same question, tux racer
 
I have had problems with Tux Racer being slow in both MDK 9.1 and RedHat 9.0 and previous versions, is there a way to make this thing go??? I had it going ONE TIME, really nice and fast, then after that I dont know what I am doing on loading the OS to make it slow.. but let me tell ya,, its SLOOOWWWW..
Anyone got any ideas?

jt1020 05-20-2003 12:07 AM

what is your video card?? i suggest that you download drivers for linux and edit your XF8Config...

320mb 05-20-2003 03:29 AM

Well I did one thing to increase system wide performance tenfold..........
Code:

hdparm -d 1 -c 1 -k 1 /dev/hda and same for /dev/hdb
.this turns on DMA and increases IO support to 32-bit.
these are recent new drives so they support this. The -k flag keeps these setting intact during uptime.
Code:

/dev/hda buffered disk reads 64 MB in 2.32 seconds = 28.70 MB/sec
Quite an increase from what it was!

jt1020 05-20-2003 10:29 AM

Quote:

Originally posted by 320mb
Well I did one thing to increase system wide performance tenfold..........
Code:

hdparm -d 1 -c 1 -k 1 /dev/hda and same for /dev/hdb
.this turns on DMA and increases IO support to 32-bit.
these are recent new drives so they support this. The -k flag keeps these setting intact during uptime.
Code:

/dev/hda buffered disk reads 64 MB in 2.32 seconds = 28.70 MB/sec
Quite an increase from what it was!

that could work too... ;)
but by installing the right drivers you would see significant increase in speed... dont forget to edit your XF86Config...

I actually had the same problem before with my games like Tux Racer and Chromium...

If you search the forums here you can actually see alot of threads similar to this one....

slightcrazed 05-20-2003 12:28 PM

If you're using an Nvidia card, then pull the latest drivers off of their site. They have an automatic driver install script (pretty slick).... after that its just a matter of editing your Xconfig file and all should be good.

slight

PrimaryDataLoop 05-20-2003 12:31 PM

No No No, you're all wrong. You need your 3d card drivers installed, not just the ones that come with your distro, tux racer uses the GLX renderer, NVIDIA's driver set has it, I was running the game fine on those (racing that damn penquin down the hill was a bitch) and recently switched to a radeon card, ive yet to install the drivers for it. regardless just get the newest drivers for your video card and install those and you should be set.

jt1020 05-20-2003 12:37 PM

you have to install linux drivers for your video card.... after you install do this:

if your using Nvidia just do this:

gedit /etc/X11/Xf86Config

find the relevant Device Section and Replace the line

Driver "nv" or "vesa"

with

Driver "Nvidia"

In the Module Section, make sure you have this:

Load "glx"

you should also remove the following lines if they exist:

Load "dri"
Load "GLcore"

this is actually in the install.doc but I feel like typing... :)

jt1020 05-20-2003 12:53 PM

Quote:

Originally posted by PrimaryDataLoop
No No No, you're all wrong. You need your 3d card drivers installed, not just the ones that come with your distro, tux racer uses the GLX renderer, NVIDIA's driver set has it, I was running the game fine on those (racing that damn penquin down the hill was a bitch) and recently switched to a radeon card, ive yet to install the drivers for it. regardless just get the newest drivers for your video card and install those and you should be set.
Thats exactly what I suggested if you read my above post..... :o

lostboy 05-20-2003 05:28 PM

I believe that jt1020 is correct. If you first change the card's drivers to the generic one included with Linux, I think it sets a few items in 'XF86Config'. Later when you install the real NVIDIA drivers, you can alter the place in XF86Config where it specifies "nv" (as posted above).

I say "I believe" because I am not 100% sure, but I think you get better results doing it this way.

This is how I do it with my NVIDIA card, so I don't know what the outcome will be if you install Linux using a vesa driver, and then going straight to the vendor's driver.

JC


All times are GMT -5. The time now is 06:40 PM.