LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-20-2002, 06:25 PM   #1
augamecock
Member
 
Registered: Feb 2002
Location: Atlanta, GA
Distribution: Debian
Posts: 78

Rep: Reputation: 15
Trying to upgrade glib to 2.0.0


I'm trying to upgrade my glib library so that I can get galeon to run. I've done everything that the INSTALL file said do and can see the my new glib 2.0 stuff is in /usr/lib...







but when I do a ./configure on galeon, it's still finding the 1.2.8 stuff?? I haven't got a clue where to go from here or even what to search on for that matter. Everything I've found doesn't apply to my situation (from what I can gather). Anyway, here's the error message.... Thanks for any help







checking for ORBit - version >= 0.5.1... no


*** Could not run ORBIT test program, checking why...


*** The test program failed to compile or link. See the file config.log for the


*** exact error that occured. This usually means ORBIT was incorrectly installed*** or that you have moved ORBit since it was installed. In the latter case, you*** may want to edit the orbit-config script: /usr/bin/orbit-config


checking for orbit-idl... /usr/bin/orbit-idl


checking for glib-config... /usr/bin/glib-config


checking for GLIB - version >= 1.2.9... no


*** Could not run GLIB test program, checking why...


*** The test program failed to compile or link. See the file config.log for the


*** exact error that occured. This usually means GLIB was incorrectly installed


*** or that you have moved GLIB since it was installed. In the latter case, you


*** may want to edit the glib-config script: /usr/bin/glib-config


configure: error:


*** GLIB 1.2.9 or better is required. The latest version of GLIB


*** is always available from ftp://ftp.gtk.org/.






Oh, well I just noticed that the ORBit thing is fubar also. On to find out what's up with that....





Oh yeah, BTW, this is Slack 7.1
 
Old 03-20-2002, 07:04 PM   #2
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
There should be an option to point ./configure to the new glib, do "./configure -help" in the galleon src directory and look for something like "--with-glib=PREFIX", replace PREFIX with the path to the new glib. Also it might be a good idea to consider upgrading to slack 8.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
how to upgrade glib without harming dependencies Kilahchris Linux - Newbie 1 09-04-2004 01:17 AM
how do I upgrade to glib 2.4.0? emanresu Linux - Software 7 04-25-2004 02:14 PM
missing file vector.h, do I need to upgrade glib++ ???? STrew Linux - Software 0 03-26-2004 07:27 AM
glib upgrade ??? webboss Linux - Software 0 10-01-2001 06:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration