-   Linux - General (
-   -   Trying to dual boot with grub. (

theupmost 03-04-2012 05:07 AM

Trying to dual boot with grub.
Hello all!

Kind of hit a snag here and could use a little help. I'm currently preparing for the Linux + certification in school. Over all I am moderately new to Linux, but do have general knowledge and can find my way around just fine.

Issue: I have an Acer Aspire One netbook. I partitioned as follows:

/dev/sda1: Fedora 16
/dev/sda2: Swap
/dev/sda3: Android 4.0 ICS i386 (found here)

However, Fedora 16 comes packaged with GRub2 (1.99) and the Android installation comes with GRub1 (0.97) Bootloaders. Both installations work just fine, however I do not no how to configure either version of grub to allow a dual boot. The Android installation either overwrites the boot loader with 0.97 or if told not to, it doesn't show up in 1.99. Installing Fedora overwrites with 1.99 but the Android installation is not detected.

I have never worked with GRub before and have not tried to edit the grub2.cfg file (I don't know exactly what to put in it).

Anybody willing to kind of walk me through it or give me some pointers? How can I manually add another entry in either bootloader (preferably GRub2) and direct it at the opposing OS? Thank you for your time.

syg00 03-04-2012 05:24 AM

Read this - it is Ubuntu, but pretty generic. Look for the "sample entry for chainloading to another GRUB bootloader."

theupmost 03-04-2012 08:46 AM

Thank you very much! Unfortunately, I wasn't able to get that to work. After doing the Fedora installation with Grub2, when I go to do the Android install, I only have 2 options for the grub1 bootloader, to install, or not to install. When I install, it only writes the bootloader to the MBR (/sda) instead of the partition (/sda3) which totally wipes out the grub2 bootloader.

I took an un-educated wack at manually creating an entry to the Android partition based off of the instructions in that article but I don't know how to get a UID for it and the "grub2-mkconfig -o /boot/grub2/grub.cfg" command says that I have invalid syntax and won't add the entry to the grub.cfg. I'm frustrated and tired of trying as of now. I will have to attempt again later today.

rng 03-04-2012 10:02 AM

It may be much easier to install grub (ver 1 or 0.97 or legacy) to mbr ie /sda and install grub2 to the partition like /sda1. Then edit /boot/grub/menu.lst file on sda3 to add following item to load grub2:

Title OS with grub2
root (hd0,0)
chainloader +1

The menu item should appear on booting and work. Note that the (hd0,0) means first disk, first partition.

Alternatively, you can install fedora with its bootloader to mbr (ie sda), and android without bootloader, then from a terminal in fedora give command as root or sudo: update-grub . This should find android installation and add it to its menu.

All times are GMT -5. The time now is 09:50 PM.