LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   trouble updating KDE (3.1 to 3.2) on SuSE (https://www.linuxquestions.org/questions/linux-general-1/trouble-updating-kde-3-1-to-3-2-on-suse-176069/)

darksmiley 04-29-2004 04:39 PM

trouble updating KDE (3.1 to 3.2) on SuSE
 
ok this kind of thing has probably been posted many times but ive already screwed updating to 3.2 up once (and only just 2day managed to piece my old KDE version back 2getha from the CD!) so im fairly paranoid ill make the same mistake again! :confused:

i only hav KDE 3.1 installed at the moment and am using SuSE 9.0. i hav downloaded most of the required packages from their site, but hav no real idea what order they must be installed in - i take it im using RPM? the problem last time was the GUI yast failed to work after KDEbase3 3.2 was installed (for obvious reasons i guess), and RPM refused to install any of the other necessary packages because of dependancies and so forth. exactly what packagages do i need and what commands must i use? i hav reasonable experience with the shell.

thanx a lot :)

darksmiley 04-29-2004 04:40 PM

*packages. lol :)

kevinatkins 04-29-2004 06:58 PM

hello darksmiley,

since you also hail from good old blighty, may i point you in the direction of the linux format coverdisc for april 2004 (lxf52). i installed kde 3.2 for suse 9.0 from the rpm's contained therein, and whilst it wasn't completely trouble-free (pay attention to the suse-specific instructions...), i've now got a mostly good kde 3.2 install - and it is better than 3.1.4! what you will lose is the suse integration and slickness, but it's more than made up for in other areas (at least in my opinion)....

darksmiley 05-01-2004 08:10 AM

i managed to do it in the end from the kde ftp server and the 'rpm -Uvh --nodeps' shell command - wasnt easy tho!! :eek:

one thing i ham having trouble with is compiling and installing window decoration and files that require the ./configure command. i cant work out what prefix it needs ive tried every directory that i think has kde in it for Suse 9 but it always comes up with - 'in the prefix you've chosen, there are no KDE headers installed'. any ideas? ive tried these /usr and /opt/kde3 and all three directories suggested by the 'whereis kde' command. plus $KDEDIRS. im confused again :confused:

makhand 05-04-2004 12:07 PM

Quote:

since you also hail from good old blighty, may i point you in the direction of the linux format coverdisc for april 2004 (lxf52).
Kevin, or someone, where do I get this coverdisk? Do I need to purchase more?

isigrin 05-08-2004 12:22 PM

Yast2 'remove and install' doesn'n work after update KDE
 
Recently I updated KDE 3.1.4 to 3.2.2 in SuSE 9.0. Although I paid attention th the SuSE instruction, Some packages complained about version conflicts. So I removed these until installation of KDE was completed. Then the removed file where installed again. After rebooting I got a new problem. Yast's 'software remove and install' has become unstable. Possible it can't find its database?
Who can help me out of this trouble? :newbie:

darksmiley 05-09-2004 07:46 AM

i got a similar problem with yast after i updating some parts of KDE but not others the first time i attempted to install the rpms. did u install ALL the rpms from ftp://ftp.kde.org/pub/kde/stable/3.2.2/SuSE/ix86/9.0/ ?

all i did when i had this problem was reinstall the old 3.1.4 from cd, and then use two terminals (on F1 and F2), one to use the command 'rpm -Uvh --nodeps' on every rpm, and the other to uninstall all of the old packages (thus resolving conflicts) using the shell version of yast. that worked really well but if u hav pretty much completed the update maybe its best just to use yast to see which packages u havnt yet updated (ie which r still v3.1.4 or the version supplied with Suse), and installing them by downloading them from the ftp and using the above method. good luck!! :)

isigrin 05-09-2004 01:50 PM

Quote:

Originally posted by darksmiley
i got a similar problem with yast after i updating some parts of KDE but not others the first time i attempted to install the rpms. did u install ALL the rpms from ftp://ftp.kde.org/pub/kde/stable/3.2.2/SuSE/ix86/9.0/ ?

all i did when i had this problem was reinstall the old 3.1.4 from cd, and then use two terminals (on F1 and F2), one to use the command 'rpm -Uvh --nodeps' on every rpm, and the other to uninstall all of the old packages (thus resolving conflicts) using the shell version of yast. that worked really well but if u hav pretty much completed the update maybe its best just to use yast to see which packages u havnt yet updated (ie which r still v3.1.4 or the version supplied with Suse), and installing them by downloading them from the ftp and using the above method. good luck!! :)

Hi darksmiley,
I did the same as you did. ftp://..../9.0
It's not clear to me why you set the command 'rpm -Uvh --nodeps' o F1 and uninstall kde packages on F2. Unfortunately yast doesn't work anymore for deleting files. Also the shell version doesn't work.:scratch:

darksmiley 05-09-2004 06:22 PM

ah. that is a problem. :eek:
tbh i had 2 look at the man entry for rpm to see exactly what all those optional parts meant:

-U upgrades the current version

-v makes the program be more verbose about what its installing and where

-h provides you with a bar composed of 50 hashes to let u know how much of the install is complete (a progress bar)

--nodeps basically means that it wont worry about whether all of the packages dependencies (ie, programs it depends on to run) are present, it will just install it. This option is good for updating the whole GUI but not for individual packages or u could end up with a very inconsistent system.

another option is -i, which installs the package without deleting an old version etc (so is to be used if u hav never installed any version of that package before).

as far as yast is concerned, u MIGHT be ok just using that command i gave u b4 followed by all of the packages from the ftp even without uninstalling them with yast, as that command updates them anyway. do u understand the idea of having several shells on Ctrl+Alt+F1 and Ctrl+Alt+F2 etc? once all of the packages r updated/installed (even with the --nodeps extension) you should hav a working KDE. let me know how u do :)

kevinatkins 05-10-2004 09:04 AM

hello makhand,

linux format is a uk magazine, to which you can subscribe, but i think it might end up being quite expensive with shipping to the USA. it's a very good read nonetheless! check out this link -

http://www.linuxformat.co.uk/modules...rticle&artid=5

hope this helps!

kevinatkins 05-10-2004 09:10 AM

oh heck!

i think i might just have broken one of the LQ.org rules by providing a link direct to another site selling services (see thread above). Apologies - no, i don't work for Linux Format magazine or Future Publishing, i was just providing info... there are, of course, lots of other ways of obtaining software and information in addition to magazines, often for free.

sorry folks if i've annoyed anyone, just got carried away with trying to help another member out.

cheers,

kevin.

darksmiley 05-10-2004 01:12 PM

*tuts* advertising on my thread.... lol :)


All times are GMT -5. The time now is 09:57 PM.