-   Linux - General (
-   -   Trouble Installing Fedora 8 onto USB thumb drive (

ed_homeLinux 12-09-2007 06:01 PM

Trouble Installing Fedora 8 onto USB thumb drive
I am trying to install Fedora 8 on a SanDisk Cruzer Micro 2 GByte USB thumb drive. I have Fedora 8 x86_64 on the hard disk. Running from the hard disk, I successfully installed the KDE LiveCD 386 version of Fedora 8 onto to the USB drive. I booted the distro "live" from the USB disk. This seems to work fine. I want to install fedora 8 onto the USB disk. I run "Install to Hard drive." I get stuck when I get to the partitioning page of the installation. I select "Remove Linux partitions on the selected drives and create default layout." The only thing that shows up in the "select drive(s) ..." is "mapper/pdc-idiiggaa 58173 MB Linux device-mapper." I have 2 60 GByte Maxtor hard drives on the system. The text is checked and grayed out. Under "What drive would you like to boot this installation from " is the same "mapper/pdc-idiiggaa ..." text. I want to boot off of the USB disk. I would like a regular installation on the USB disk. How do I proceed. Thanks.


I want to install Fedora onto this USB disk and take it to a Windows machine running Windows XP.

XavierP 12-10-2007 03:53 AM

Moved: This thread is more suitable in Linux-General and has been moved accordingly to help your thread/question get the exposure it deserves.

tecnalb 12-12-2007 10:11 PM

I've done much of what you want to do. First, to do a Read-Write F8 on USB you need to have at least 4GB. I bought an 8GB. I have a similar setup as you. F8_64 on the PC. I used to F8-LiveCD_i686.iso and the livecd-iso-to-disk tools to place the read-only version on the same Sandisk Cruzer keys. I've built 5 or 6, and they work pretty well.

Your problem MAY be that your Cruzer is formatted FAT16. That would prevent you from seeing the key as the LiveCD. Get a larger key, and select to REMOVE ALL PARTITIONS. Then you should see the key as something like "sdc" is the available drive box.

Something else you can try if boot to your desktop, use gparted and remove the partitions, the create a new partition ext3. But you will need to get a larger key, OR take two keys and use LVM during the install to create a 4GB partition across both keys :-)

My issue is I'm trying to MODIFY the livecd image, resquash the filesystem, and place back on the 2GB key, to have a modified read only key. Nobody seems to be able to help me in this area.... we'll figure it out sometime I suppose.

ed_homeLinux 12-15-2007 09:24 AM

I got a 4 GByte SanDisk Cruzer USB stick. I was able to install the Gnome i686 version of fedora 8 on the key with livecd-iso-to-disk. I was also able to boot from the usb stick. However, I was not able to install the system to the usb stick like you could to a hard drive. When I tried to install it to the stick, the installation went to the hard drive. Do you have any suggestions?

ed_homeLinux 12-15-2007 08:15 PM

The Linux format magazine did an article on remastering (i.e. modifying) a Knoppix based LiveCD. There is documentation on that around on the web. I think that you can change various settings and easily make a new live cd with PCLinuxOS. For Fedora, you can make a custom live cd with revisor. I have brought this program up, but haven't used it. Finally, what happens if you run

qemu -cdrom Fedora-8-Live-i686.iso -m 512 -std-vga

and then use the "install to hard disk" feature. Does it actually install to the hard disk? I suppose that this doesn't modify the iso file.

ed_homeLinux 12-16-2007 05:32 PM

I shut down the machine, removed the power to the hard drives, and rebooted the machine off of the USB stick. The live image on the stick works great. However, I still can't run "Install to Hard Drive." On the page about where to install, there is nothing listed for both "Select the drive(s) to use for this installation" and "What drive would you like to boot this installation from" If I try to continue to the next page anyway, I get the following message "An error has occurred. No valid drives were found on which to create new file systems. Please check your hardware for the cause of this problem."

tecnalb 12-17-2007 10:45 PM

Have you tried booting the LIveCD from a cdrom and installing to a stick? I can't imagine it would give you the option to install to the same stick you are booting from, or did I misunderstand you?

All times are GMT -5. The time now is 10:32 PM.