-   Linux - General (
-   -   "Transport endpoint is not connected" - how to diagnose or fix? (

monguin61 03-14-2013 11:22 AM

"Transport endpoint is not connected" - how to diagnose or fix?
Once in a while, one of the four hard disks inside my desktop ceases to be accessible, giving a "Transport endpoint is not connected" error when I try to access it in any way. I've briefly searched for solutions to this online, but have not found any relevant solutions (many posts I've found seem to be for SSH or other networking issues; the problem is entirely confined to one machine for me). When it happens, I temporarily lose access to all of my personal documents, so I have no choice but to reboot the machine, as that is the only solution I know right now. I figured that remounting it might do something, but I'm afraid to try anything that I'm not certain won't destroy data. Sometimes it happens when I am in the middle of moving files around on the drive; sometimes it happens while I am away from the machine and it is just idling.

I do not know how to fix, or even diagnose this issue. I do not know whether it is a software or a hardware issue - the machine is about 5 years old, and the disk is probably 3-4 years old, so I won't be surprised if it turns out to be a hardware issue. However, the Linux installation is screwed up in several other ways as well, so I can't rule out a software issue either.

Does anyone have any suggestions for how to fix or diagnose this? The problem is intermittent and unpredictable, so I will try any suggestions as soon as possible, but I don't know when that will be.

This is in Linux Mint 14, on a ~5 year old 32bit Intel desktop machine. The disk is a 3-4 year old 500GB Western Digital drive (platter, not solid state. I believe it is SATA, but might be wrong about that, I can check later if necessary). It has also happened in previous installations of various Ubuntus on the same machine, but seems to be getting more common now. The current installation is kind of screwy for other reasons as well, but this is the only issue that causes any real problems.

Thanks for any help.

onebuck 03-14-2013 01:09 PM

Member Response

Welcome to LQ!

First, you should look at the logs to see if anything is being reported or at fault. Look in '/var/log' and 'dmesg' could provide some insight.

You should consider reading the following;

FYI: Netiquette is a set of social conventions that facilitate interaction over networks, ranging from Usenet and mailing lists to blogs and forums.

FYI: I suggest that you look at 'How to Ask Questions the Smart Way' so in the future your queries provide information that will aid us in diagnosis of the problem or query.
You can run manufacture hard disk diagnostics or smartctl;

excerpt from 'man smartctl';
smartctl - Control and Monitor Utility for SMART Disks

smartctl [options] device


smartmontools-5.43 2012-06-30 r3573

[This man page is generated for the Linux version of smartmontools. It does not contain info specific to other platforms.]

smartctl controls the Self-Monitoring, Analysis and Reporting Technology (SMART) system built into many ATA-3 and later ATA, IDE and SCSI-3 hard
drives. The purpose of SMART is to monitor the reliability of the hard drive and predict drive failures, and to carry out different types of drive
self-tests. This version of smartctl is compatible with ATA/ATAPI-7 and earlier standards (see REFERENCES below)

smartctl is a command line utility designed to perform SMART tasks such as printing the SMART self-test and error logs, enabling and disabling SMART
automatic testing, and initiating device self-tests. Note: if the user issues a SMART command that is (apparently) not implemented by the device,
smartctl will print a warning message but issue the command anyway (see the -T, --tolerance option below). This should not cause problems: on most
devices, unimplemented SMART commands issued to a drive are ignored and/or return an error.

smartctl also provides support for polling TapeAlert messages from SCSI tape drives and changers.

The user must specify the device to be controlled or interrogated as the final argument to smartctl. The command set used by the device is often
derived from the device path but may need help with the -d option (for more information see the section on "ATA, SCSI command sets and SAT" below).
Please consider reading the 'man smartctl' for options & switches.

Or use;

SystemRescueCd is a Linux system on a bootable CD-ROM for repairing your system and recovering your data after a crash. It aims to provide an easy way to carry out admin tasks on your computer, such as creating and editing the partitions of the hard disk. It contains a lot of system utilities (parted, partimage, fstools, ...) and basic tools (editors, midnight commander, network tools). You can look at the 'Online-Manual'.

UBCD Ultimate Boot CD allows users to run floppy-based diagnostic tools from most CDROM drives on Intel-compatible machines, no operating system required. The CD includes many diagnostic utilities that are very useful.

Please consider scrolling down within this thread and look at 'similar threads' for some potential helpful information.
Hope this helps!

onebuck 03-14-2013 01:16 PM

Member Response

One other thing for 'Transport endpoint is not connected'. You could have issues with a DB or something associated with 'samba' as an example. You could be having issue with 'metadata' for applications or misconfiguration config files for application(s).

I would still check out the hardware.

gradinaruvasile 03-14-2013 01:45 PM

If the errors happen during copy, it might be hardware (read or write) error. dmesg in thses cases shows some info about the error nature and unreadable/writable physical sector numbers.

chrism01 03-15-2013 02:25 AM

Could even be a hot fault at the HW level. Over time the heating / cooling down can cause the plug connectors to work slightly loose.
Try shutdown, wait 5 mins, then open the case and re-seat the connectors.

monguin61 04-01-2013 03:22 PM

Thanks for the suggestions, but I have not had a chance to check any of them yet. I have had the problem again only once since my first post here; I tried remounting the drive and it seemed to work without trouble. I will look at the logs when I can.

PTrenholme 04-01-2013 05:41 PM

I suggest a SERIOUS look at the logs, especially for "drive error" or "remounting as read only" ones.

What you're seeing is, in my opinion, the result of an intermittent drive failure. (Hopefully, just a loose or tarnished connector which is often cured by unplugging and replugging the drive cable -- with the power off, of course.)

Habitual 04-01-2013 05:59 PM

I used to get this message when I had stale mounts and I tried to use my sshfs to sync.
The fix was umount, then mount.

monguin61 04-03-2013 09:08 AM

I had a chance to examine the machine after this occurred again. I didn't have much time, so all I did was save the output of dmesg. Below are a few apparently relevant lines near the end, and the full output is available here: . I'm going to search for information on these messages on my own, but if anyone can identify an obvious solution quickly, I'd appreciate some info. Thanks.


[ 1277.808819] sdg: detected capacity change from 16009658368 to 0
[ 2019.948150] sd 8:0:0:0: >[sdg] 31268864 512-byte logical blocks: (16.0 GB/14.9 GiB)
[ 2019.949641] sd 8:0:0:0: >[sdg] No Caching mode page present
[ 2019.949646] sd 8:0:0:0: >[sdg] Assuming drive cache: write through
[ 2019.951763] sd 8:0:0:0: >[sdg] No Caching mode page present
[ 2019.951767] sd 8:0:0:0: >[sdg] Assuming drive cache: write through
[ 2019.953463]  sdg: sdg1
[ 2041.654894] sdg: detected capacity change from 16009658368 to 0

I'm not sure why 'sdg' is listed in these messages, running mount shows no device at /dev/sdg*. I'm also not sure what the "capacity change" means - if the 16009658368 refers to bytes, then it's about 15GB, and I don't have any drive with that size or that amount of free space.

a8a 05-11-2013 08:10 PM

This is a bug, it is solved in

Lixin Chin (wstfgl) wrote on 2013-04-29: #26
To everyone looking for a "quick fix" to this issue:

Grab the packages 'fuse' and 'libfuse2' from the debian package archive. Get the package for your appropriate architecture (probably amd64 if you're using 64-bit, else i386).

I've been using versions 2.9.2-2, but the latest appears to be 2.9.2-4, not sure what's changed, but it's probably minor.

Install both packages "sudo dpkg -i ..."

Reboot, and you should be good to go. I've had no problems since installing 2.9.2 back in February, and I've used my ntfs filesystem on a daily basis since then.

Disappointing that 13.04 was allowed to release with such a glaring bug still present.

monguin61 05-12-2013 09:14 AM

Great, thanks for your help.

monguin61 09-05-2013 07:03 PM

For future readers: I got rid of Mint and installed Xubuntu (12.04) about two months ago, and have not had this problem since.

All times are GMT -5. The time now is 12:26 PM.