-   Linux - General (
-   -   TFTP-Problem: TFTP timed out (

Bikerpete 06-27-2003 06:55 AM

TFTP-Problem: TFTP timed out
I`m stuck in a TFTP-Problem!!!
I installed the Linux Terminal Server Project "www ltsp org" on a SuSE 8.2 server, but I canīt connect to my TFTP-Server. I wanted to use my Linux-Server as a Terminal-Server for a diskless client.
I got the bootdisk from www rom-o-matic .com
I get a IP-address and the client tries to download the kernel from the /tftpboot directory.
TFTP ist startet with the "-s"-option - so I defined the kernel-path as "/lts/vmlinuz-2.4.19-ltsp-1".
All I get is a row of points, but nothing happens.
So I tried TFTP directly on the server with "tftp localhost" and "get /lts/vmlinuz-2.4.19-ltsw-1", but the result is only "connection timed out.
I set the "hosts.allow" to ALL and leaved the "hosts.deny" empty.
The client is defined in /etc/dhcpd.conf.
Looks, like another sleepless night at the prompt
Every help is welcome !;) :p

homer12 08-13-2003 02:34 AM

With regards to TFTP, I have already confirmed that the daemon is running and even the status says that a connection has been made, I am getting the time out error and I need help.:confused: Was your problem resolvbed?

Bikerpete 08-14-2003 05:25 AM

Server-Port 69 open?
I solved the problem:

I just turned off the Firewall on my SuSE-Server.
Then my TFTP worked well. Clients send their requests from a portrange over 1023 to port 69 on UDP.
So you can try to open these ports ...
Ahem ... I reconfigured my firewall .. now it works ith my firewall on
God luck ...

All times are GMT -5. The time now is 11:26 PM.