-   Linux - General (
-   -   System experiencing short "hiccups" / hangers (

FnordPerfect 12-25-2006 11:40 PM

System experiencing short "hiccups" / hangers
Hi there,

(I just declared myself Eternal Newbie, so I'll go ahead and post my question as if I had not been using Linux for the past 5 yrs...)

Well, as the topic says, there are occasional hiccups in some apps (games..).
For example these:
* sdljump
* E-UAE (enhanced Amiga emulator using SDL)
* dosbox

Every x seconds the app hangs, but only the graphical output. The app continues playing sound and receiving input, and then suddenly the display "catches up"..!

My guess would be, that it is either a threading issue, something that has to do with scheduling on kernel-level, or perhaps an ALSA buffer issue -- who knows? I just don't know where to start investigating... :confused:

It might be completely unrelated, but Firefox (or rather Swiftfox 2.0 which I use) also shows a similar behaviour:
My input (may it be via mousewheel or keyboard) does not trigger actions immediatly, but it *is received* and the window scrolls / the textbox fills
a few milliseconds later, according to my input...

This is my setup:
* Debian SID

* customized Kernel 2.6.19-ck1 (yep, I'm using the Con Kolivas patchset -- perhaps this is the "root of all evil"? ;-) dunno!)

* I am running various daemons and background processes, but the system load is normally at 1-3 %

* Athlon XP 2500+, 1GB RAM
* Geforce TI4200 (using the proprietary Nvidia drivers 1.0-9631)
* SB Live! using ALSA (OSS emulation layer turned off, I'm using no artsd or similar)

Please help!

Fabian (FnordPerfect)

rylan76 12-26-2006 05:59 AM


I'm using FC6 with the kernel. I had similar problems under load with a the kernel compiled for pre-emptiveness. I had this set, and then I had problems like yours (this is the relevant lines in the kernel source's .conf file):


This meant (I guess - bit of a newbie myself) that the kernel was running a "forced pre-emptive" mode as regards scheduling. I changed this to

# CONFIG_PREEMPT is not set

(i. e. I compiled a volunatrily pre-emptive kernel) and my hickups and stutterings went away, under load or not.

Maybe you can try doing this as well? Maybe it will solve your stuttering problems?


FnordPerfect 12-29-2006 08:34 AM

Hello, thank you very much for your detailed answer!

I checked, but alas my kernel was already compiled for voluntary pre-emption.

So I thought I give it a shot and tried what happens with forced pre-emption, which I am trying atm, and yes, it made it even worse. The next thing I'll try is to patch the kernel with the -ck2 patchset to see if things change. Then perhaps try a vanilla-Debian kernel.

It's not in that many applications, anyway! But sdljump this stuttering is extremly noticeable. Maybe that silly game is just not a reliable benchmark, and the most effective cure for my problem is stop playing it ;-)

Fabian (fnordperfect)

rylan76 12-31-2006 04:44 AM

Ok, have you tried a kernel with NO pre-emption? Not voluntary OR forced?

FnordPerfect 01-09-2007 12:08 PM

Yes, I recompiled my kernel three times, but the problem never went away completely.

I am sure I just looked at it from the wrong side:
When I tried sdljump at a friend's computer, it experienced the very same problem. He then fiddled around with the settings of that game, and it went away.

E-UAE and Firefox show a similar behaviour superficially, but it is probably a completely differend problem under the hood.

Thanks for your help, anyway.

All times are GMT -5. The time now is 03:35 AM.