LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-19-2003, 02:25 PM   #1
Tiago Cruz
Member
 
Registered: Jan 2003
Location: Brasil - São Paulo
Distribution: RHEL, SuSE, *BSD, Debian
Posts: 36

Rep: Reputation: 15
Red face Swat => " The document contains no data" <- RH8


Hi 4 all!!

After hours and hours, the port 901 (Swat) is openned in RH8.0

Quote:
root@MAQ711 etc]# cat /etc/xinetd.d/swat
# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
# to configure your Samba server. To use SWAT, \
# connect to port 901 with your favorite web browser.
service swat
{
disable = no
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
}
[root@MAQ711 etc]#
But the message The document contains no data apperar when: http://192.168.6.51:901/

Note: http://localhost:901/ and http://127.0.0.1:901/ aren`t functional

(Sorry by bad english :-( )
 
Old 02-19-2003, 02:32 PM   #2
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 825

Rep: Reputation: 30
is that using mozilla/netscape?
 
Old 02-19-2003, 02:37 PM   #3
Tiago Cruz
Member
 
Registered: Jan 2003
Location: Brasil - São Paulo
Distribution: RHEL, SuSE, *BSD, Debian
Posts: 36

Original Poster
Rep: Reputation: 15
Yeah!!!

Mozilla and Galeon

My desktop with SuSE have swat, and is functional if I type:
http://192.168.7.3:901

But in the server this message appear...
http://192.168.6.51:901

I remove iptables but nothing...

Thank's!!!!
 
Old 02-19-2003, 05:26 PM   #4
Csurfer
LQ Newbie
 
Registered: Feb 2003
Distribution: RedHat 8.0
Posts: 3

Rep: Reputation: 0
1. Is there a /etc/samba/smb.conf file?

2. Does /etc/services have "swat 901/tcp #swat" in it?

3. Assuming that the config you first posted was in you /etc/xinetd.d/swat file, it should NOT be duplicated in you /etc/xinetd.conf file.
Also, I have the IP address that my router gives me in the /etc/xinetd.d/swat file along with the loopback ip.
Like this/
only_from = 127.0.0.1 192.168.1.102

4. Go to the GNOME or KDE menu --> Server Settings --> Services. Make sure that you have xinetd and smb checked and started, also make sure that swat is checked.

Also, might want to check you /etc/hosts /etc/hosts.allow /etc/lmhosts and /etc/samba/lmhosts files

Good Luck!
 
Old 02-20-2003, 06:44 AM   #5
Tiago Cruz
Member
 
Registered: Jan 2003
Location: Brasil - São Paulo
Distribution: RHEL, SuSE, *BSD, Debian
Posts: 36

Original Poster
Rep: Reputation: 15
Hei Csurfer,
Thank`s for reply

1-) Yeah, samba is functional, vi /etc/samba/smb.conf rulez

2-)
Code:
 [root@MAQ711 root]# cat /etc/services | grep swat
swat            901/tcp                         # Samba Web Administration Tool
3-) Yes, is my /etc/xinetd.d/swat...

Code:
[root@MAQ711 etc]# cat /etc/xinetd.conf

# Some defaults, and include /etc/xinetd.d/
defaults
{
        instances               = 60
        log_type                = SYSLOG authpriv
        log_on_success          = HOST PID
        log_on_failure          = HOST
        cps                     = 25 30
}
includedir /etc/xinetd.d

4-)
Code:
[root@MAQ711 root]# chkconfig --list | grep swat
        swat:   on
[root@MAQ711 root]# chkconfig --list | grep xinetd
xinetd          0:off   1:off   2:off   3:on    4:on    5:on    6:off
xinetd based services:
[root@MAQ711 root]#
This files are ok???

Code:
[root@MAQ711 etc]# cat /etc/samba/lmhosts
127.0.0.1 localhost

root@MAQ711 etc]# cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       MAQ711  localhost.localdomain   localhost
Hosts.allow and hosts.deny are only comment

Iptables and Ipchains not are installed...

Please, check if my files are = your files, ok?

Thank`s again

Last edited by Tiago Cruz; 02-20-2003 at 06:48 AM.
 
Old 02-20-2003, 07:10 AM   #6
Tiago Cruz
Member
 
Registered: Jan 2003
Location: Brasil - São Paulo
Distribution: RHEL, SuSE, *BSD, Debian
Posts: 36

Original Poster
Rep: Reputation: 15
Yeeaahhh!!!!

Resolution:

In mozilla / galeon:

No Proxy for: localhost, 127.0.0.1

Only This

Thank's for help!!!!
 
Old 09-03-2003, 08:57 AM   #7
roby
LQ Newbie
 
Registered: Aug 2003
Location: Germany
Distribution: RedHat
Posts: 1

Rep: Reputation: 0
Unhappy Still "The document contains no data"

Hi!

ehm... I read all the postings (I believe).
I couldn't use swat at all and reading http://www.linuxhelpnetwork.net/foru...opic.php?t=580
I found out that my new installed RedHat 9 didn't install swat at all, so I installed the rpm I got from RedHat as explained in the link above.

I changed the /etc/xinetd.d/swat file "Disable = No" (the rest is the same as in this posting)

I checked the /etc/services file (there is swat 901/tcp)

I commented my hosts.allow and hosts.deny files (now ALL:ALL should be enabled

The services SMB and SWAT are on (I checked with chkconfig --list).

In my "Preferences/Advanced/Proxies" setting for mozilla I have checked "Direct connection to the internet"

I still get (trying 127.0.0.1:901 or my.ip.adr.ess:901) the message "The document contains no data"

and I really don't know where else I can check!!!

Thanks in advance for your reply.

Roby

P.S.: I made and checked all the things that are in this (and other posting) so I don't even know which other information about my installation you need

P.P.S.: byside: if (with mozilla) I try to connect to localhost:901 it will start to search ("trying to connect") to www.localhost.com ... I didn't find where to change this setting in the "Preferences" of Mozilla
 
Old 10-14-2003, 07:53 PM   #8
barrister
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Folks,

Had the document contains no data problem....

Fixed it by changing the only_from = 127.0.0.1 to only_from = 192.168.0.5
and then accessing via the web browser on 192.168.0.5:901

Using the localhost address appears to cause issues, I recommend using your
machines main ip address from eth0.

This can be got by using ifconfig

rgs,

barrister
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mozilla or firefox : "ALERT document contains no data!" maxut Fedora 8 06-08-2006 09:12 AM
Apache and Firefox "Document contains no data" error. ]SK[ Linux - Software 0 08-16-2005 02:44 AM
Mozilla/Firefox "Document contains no data" e88z4 Linux - Software 16 02-09-2005 03:14 AM
"document contains no data" error when i try to connect to SWAT on local machine squeaky-steve Linux - Networking 2 12-03-2003 09:12 AM
apache2 w/ ssl - "document contains no data" with https tree_buddy Linux - Security 2 11-23-2003 09:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration