LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Strange ERROR on 2.6.15.5 compile (https://www.linuxquestions.org/questions/linux-general-1/strange-error-on-2-6-15-5-compile-421614/)

__spc__ 03-04-2006 02:09 PM

Strange ERROR on 2.6.15.5 compile
 
Hi,

I took a linux-free desktop today and installed Slack 10.1 (2.4.29), and I then configured WiFi and upgraded to KDE 3.5.1 and kernel 2.6.15.5.

No problem so far (apart from when I removed KDE 3.3, I zapped by mistake the 2.4.29 sources).

I have now realized that I mistakenly omitted to include support for ntfs, so I want to recompile 2.6.15.5.

I do make mrproper, then make menuonfig, and I get this error:
HOSTCC scripts/basic/fixdep
In file included from /usr/include/bits/posix1_lim.h:153,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:122,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/syslimits.h:7,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:11,
from scripts/basic/fixdep.c:113:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
In file included from /usr/include/sys/socket.h:35,
from /usr/include/netinet/in.h:24,
from /usr/include/arpa/inet.h:23,
from scripts/basic/fixdep.c:115:
/usr/include/bits/socket.h:304:24: asm/socket.h: No such file or directory
scripts/basic/fixdep.c: In function `use_config':
scripts/basic/fixdep.c:201: error: `PATH_MAX' undeclared (first use in this function)
scripts/basic/fixdep.c:201: error: (Each undeclared identifier is reported only once
scripts/basic/fixdep.c:201: error: for each function it appears in.)
scripts/basic/fixdep.c:201: warning: unused variable `s'
scripts/basic/fixdep.c: In function `parse_dep_file':
scripts/basic/fixdep.c:297: error: `PATH_MAX' undeclared (first use in this function)
scripts/basic/fixdep.c:297: warning: unused variable `s'
make[1]: *** [scripts/basic/fixdep] Error 1
make: *** [scripts_basic] Error 2

I have reinstalled the source for 2.4.29 (and it allows make menuconfig with no errors), but I still get this error for 2.6.15.5.

Can someone please tell me what I need to do to get 2.6.15.5 to compile again (I have re-untar'ed the source, but still no dice).

__spc__ 03-04-2006 02:34 PM

Sussed it - I deleted the 2.4.29 headers; now reinstalled and all works well.


All times are GMT -5. The time now is 03:55 AM.