-   Linux - General (
-   -   Strange behaviour with new Kernel (

sausagejohnson 04-14-2004 12:19 AM

Strange behaviour with new Kernel
Hi Guys. I have been using the stock 2.6.3 kernel on Fedora Core 1 for a few days and decided to compile 2.6.4.

I began the usual steps and noticed from the console output with 'make xconfig' that it loaded my /boot/config-2.6.x file. I thought this was handy as I didn't have to load it in manually. I also noticed that a few lines appeared relating to items that aren't applicable in the config file (that's how I interpreted it).

Moving on... compiled the kernel, and modules, installed, updated grub and reboot. I can load my new kernel 2.6.4 fine. Everything seemed to be ok but I couldn't ping my other box on the local lan.

I tried to run the redhat network config tool and it wouldn't come up. So I ran it from the xterm to check the output and I get a stack of python errors.

In fact, all my network related config tools gave python errors and wouldn't load. I could ping myself ok, but not the other box. A quick reboot to kernel 2.6.3 and my network is fine. I can ping the other box and bring up the network app in kde.

So my general question is, it must have something to do with missing a selection in the xconfig when compiling the kernel, but when it automatically attempted to load my old config, I thought it should be ok.

Any general advice on what I might be missing?

American Psycho 04-14-2004 01:41 AM

look in the network sections under your kernel config as well, that may be part of it too

sausagejohnson 04-14-2004 01:50 AM

Yep I'll check that out. I was starting to wonder whether the version of python didn't like 2.6.4 but I think that's probably silly. It would more likely be me dropping a module in xconfig.

sausagejohnson 04-16-2004 01:36 AM

Well I tried again. Used xconfig and went thoroughly through the network section before compiling. Same result. Networking X apps give heaps of python errors and I can't ping other machines except myself.

Anyone might know what's going on here?

2.4 kernels I have compiled, have always been fine.

AutOPSY 04-16-2004 11:54 PM

Try upgrading your version of GCC to 3.3.3 or get module-init-tools 3.0 or upgrade your python package that is screwy.

sausagejohnson 04-18-2004 06:21 PM

Maybe I'll just get Core 2 and start again.

All times are GMT -5. The time now is 01:46 AM.